summary refs log tree commit diff
path: root/nixos/modules/system/boot/systemd-nspawn.nix
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2017-05-19 21:42:20 +0100
committerJörg Thalheim <joerg@thalheim.io>2017-05-20 20:31:38 +0100
commit4698012c5275395d2b2579ccb4a4337774b41229 (patch)
tree92ce9599adbc09a934e7c0fd2d827cf12b6ce908 /nixos/modules/system/boot/systemd-nspawn.nix
parentb2a14ee339fa7d328b9d896731803d57d39ded6b (diff)
downloadnixlib-4698012c5275395d2b2579ccb4a4337774b41229.tar
nixlib-4698012c5275395d2b2579ccb4a4337774b41229.tar.gz
nixlib-4698012c5275395d2b2579ccb4a4337774b41229.tar.bz2
nixlib-4698012c5275395d2b2579ccb4a4337774b41229.tar.lz
nixlib-4698012c5275395d2b2579ccb4a4337774b41229.tar.xz
nixlib-4698012c5275395d2b2579ccb4a4337774b41229.tar.zst
nixlib-4698012c5275395d2b2579ccb4a4337774b41229.zip
systemd-nspawn: add NotifyRead option
Diffstat (limited to 'nixos/modules/system/boot/systemd-nspawn.nix')
-rw-r--r--nixos/modules/system/boot/systemd-nspawn.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/nixos/modules/system/boot/systemd-nspawn.nix b/nixos/modules/system/boot/systemd-nspawn.nix
index f765db275e79..788a13c27ca6 100644
--- a/nixos/modules/system/boot/systemd-nspawn.nix
+++ b/nixos/modules/system/boot/systemd-nspawn.nix
@@ -14,11 +14,12 @@ let
     (assertOnlyFields [
       "Boot" "ProcessTwo" "Parameters" "Environment" "User" "WorkingDirectory"
       "Capability" "DropCapability" "KillSignal" "Personality" "MachineId"
-      "PrivateUsers"
+      "PrivateUsers" "NotifyReady"
     ])
     (assertValueOneOf "Boot" boolValues)
     (assertValueOneOf "ProcessTwo" boolValues)
     (assertValueOneOf "PrivateUsers" (boolValues ++ [ "pick" ]))
+    (assertValueOneOf "NotifyReady")
   ];
 
   checkFiles = checkUnitConfig "Files" [
@@ -82,7 +83,7 @@ let
 
   };
 
-  instanceToUnit = name: def: 
+  instanceToUnit = name: def:
     { text = ''
       [Exec]
       ${attrsToSection def.execConfig}