summary refs log tree commit diff
path: root/nixos/modules/system/boot/stage-2.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 11:02:04 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 14:57:42 +0100
commit862e3dd977cdd853c3ab3202ab1b73561f8a3ea1 (patch)
tree43e95414e328ac92383bccf41219c30fa9729473 /nixos/modules/system/boot/stage-2.nix
parent162b874469935923dec02cc9a6b5f58b1c8267a8 (diff)
downloadnixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.tar
nixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.tar.gz
nixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.tar.bz2
nixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.tar.lz
nixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.tar.xz
nixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.tar.zst
nixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.zip
Substitute "types.uniq types.string" -> "types.str"
Diffstat (limited to 'nixos/modules/system/boot/stage-2.nix')
-rw-r--r--nixos/modules/system/boot/stage-2.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/modules/system/boot/stage-2.nix b/nixos/modules/system/boot/stage-2.nix
index ff17535e418e..0af4c9f7a582 100644
--- a/nixos/modules/system/boot/stage-2.nix
+++ b/nixos/modules/system/boot/stage-2.nix
@@ -52,7 +52,7 @@ in
       devSize = mkOption {
         default = "5%";
         example = "32m";
-        type = types.uniq types.string;
+        type = types.str;
         description = ''
           Size limit for the /dev tmpfs. Look at mount(8), tmpfs size option,
           for the accepted syntax.
@@ -62,7 +62,7 @@ in
       devShmSize = mkOption {
         default = "50%";
         example = "256m";
-        type = types.uniq types.string;
+        type = types.str;
         description = ''
           Size limit for the /dev/shm tmpfs. Look at mount(8), tmpfs size option,
           for the accepted syntax.
@@ -72,7 +72,7 @@ in
       runSize = mkOption {
         default = "25%";
         example = "256m";
-        type = types.uniq types.string;
+        type = types.str;
         description = ''
           Size limit for the /run tmpfs. Look at mount(8), tmpfs size option,
           for the accepted syntax.