summary refs log tree commit diff
path: root/nixos/modules/system/boot/stage-1.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2016-04-01 17:30:34 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2016-04-01 17:39:09 +0200
commitf2af8874e8fa2265d1847d8fec9cc271de7f2efa (patch)
treede9ffb856220b2c6e04828e342fabb63aba64697 /nixos/modules/system/boot/stage-1.nix
parent7dd90837b13e31d7990981747caef14bd91147ad (diff)
downloadnixlib-f2af8874e8fa2265d1847d8fec9cc271de7f2efa.tar
nixlib-f2af8874e8fa2265d1847d8fec9cc271de7f2efa.tar.gz
nixlib-f2af8874e8fa2265d1847d8fec9cc271de7f2efa.tar.bz2
nixlib-f2af8874e8fa2265d1847d8fec9cc271de7f2efa.tar.lz
nixlib-f2af8874e8fa2265d1847d8fec9cc271de7f2efa.tar.xz
nixlib-f2af8874e8fa2265d1847d8fec9cc271de7f2efa.tar.zst
nixlib-f2af8874e8fa2265d1847d8fec9cc271de7f2efa.zip
Revert "initrd: Use modprobe from busybox"
This reverts commit 45c218f893d38f94cd62fc256117b9fb1a0d1749.

Busybox's modprobe causes numerous "Unknown symbol" errors in the
kernel log, even though the modules do appear to load correctly.
Diffstat (limited to 'nixos/modules/system/boot/stage-1.nix')
-rw-r--r--nixos/modules/system/boot/stage-1.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/nixos/modules/system/boot/stage-1.nix b/nixos/modules/system/boot/stage-1.nix
index 757d883373ac..7b13a305f035 100644
--- a/nixos/modules/system/boot/stage-1.nix
+++ b/nixos/modules/system/boot/stage-1.nix
@@ -67,6 +67,10 @@ let
         copy_bin_and_libs $BIN
       done
 
+      # Copy modprobe.
+      copy_bin_and_libs ${pkgs.kmod}/bin/kmod
+      ln -sf kmod $out/bin/modprobe
+
       # Copy resize2fs if needed.
       ${optionalString (any (fs: fs.autoResize) (attrValues config.fileSystems)) ''
         # We need mke2fs in the initrd.