summary refs log tree commit diff
path: root/nixos/modules/system/boot/stage-1.nix
diff options
context:
space:
mode:
authorMartin Wohlert <martin@b-root-force.de>2017-05-22 20:07:04 +0200
committerNikolay Amiantov <ab@fmap.me>2017-07-26 20:57:10 +0300
commitc3d5cfdc3ca709a9c5081b1a11bca533bc4788af (patch)
treefdb842d855be305a8ce94529aee3e97aa21cd8e0 /nixos/modules/system/boot/stage-1.nix
parent81e998bf0c723c8d0ebb3d1bf8615c88b46bccc8 (diff)
downloadnixlib-c3d5cfdc3ca709a9c5081b1a11bca533bc4788af.tar
nixlib-c3d5cfdc3ca709a9c5081b1a11bca533bc4788af.tar.gz
nixlib-c3d5cfdc3ca709a9c5081b1a11bca533bc4788af.tar.bz2
nixlib-c3d5cfdc3ca709a9c5081b1a11bca533bc4788af.tar.lz
nixlib-c3d5cfdc3ca709a9c5081b1a11bca533bc4788af.tar.xz
nixlib-c3d5cfdc3ca709a9c5081b1a11bca533bc4788af.tar.zst
nixlib-c3d5cfdc3ca709a9c5081b1a11bca533bc4788af.zip
swap: extend randomEncryption to plainOpen and ability to select cipher
Diffstat (limited to 'nixos/modules/system/boot/stage-1.nix')
-rw-r--r--nixos/modules/system/boot/stage-1.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/stage-1.nix b/nixos/modules/system/boot/stage-1.nix
index 02870878c0f3..d6e3e3a87d01 100644
--- a/nixos/modules/system/boot/stage-1.nix
+++ b/nixos/modules/system/boot/stage-1.nix
@@ -207,7 +207,7 @@ let
       preLVMCommands preDeviceCommands postDeviceCommands postMountCommands preFailCommands kernelModules;
 
     resumeDevices = map (sd: if sd ? device then sd.device else "/dev/disk/by-label/${sd.label}")
-                    (filter (sd: hasPrefix "/dev/" sd.device && !sd.randomEncryption
+                    (filter (sd: hasPrefix "/dev/" sd.device && !sd.randomEncryption.enable
                              # Don't include zram devices
                              && !(hasPrefix "/dev/zram" sd.device)
                             ) config.swapDevices);