summary refs log tree commit diff
path: root/nixos/modules/system/boot/stage-1.nix
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas.tynkkynen@iki.fi>2016-02-06 13:46:52 +0200
committerTuomas Tynkkynen <tuomas.tynkkynen@iki.fi>2016-04-15 01:53:34 +0300
commitab428dce14f3dacd61e073eba14a9a9c9fcdde03 (patch)
tree3972bbd900a67546dea1597edce04d15a184630a /nixos/modules/system/boot/stage-1.nix
parent9cc1b065ca44047a5c7f226bd6308c55d4555cb6 (diff)
downloadnixlib-ab428dce14f3dacd61e073eba14a9a9c9fcdde03.tar
nixlib-ab428dce14f3dacd61e073eba14a9a9c9fcdde03.tar.gz
nixlib-ab428dce14f3dacd61e073eba14a9a9c9fcdde03.tar.bz2
nixlib-ab428dce14f3dacd61e073eba14a9a9c9fcdde03.tar.lz
nixlib-ab428dce14f3dacd61e073eba14a9a9c9fcdde03.tar.xz
nixlib-ab428dce14f3dacd61e073eba14a9a9c9fcdde03.tar.zst
nixlib-ab428dce14f3dacd61e073eba14a9a9c9fcdde03.zip
stage-1: Remove doublePatchelf hack
No longer needed with the new patchelf version.
Diffstat (limited to 'nixos/modules/system/boot/stage-1.nix')
-rw-r--r--nixos/modules/system/boot/stage-1.nix4
1 files changed, 0 insertions, 4 deletions
diff --git a/nixos/modules/system/boot/stage-1.nix b/nixos/modules/system/boot/stage-1.nix
index 7e84dd204773..5e6554324ca4 100644
--- a/nixos/modules/system/boot/stage-1.nix
+++ b/nixos/modules/system/boot/stage-1.nix
@@ -31,7 +31,6 @@ let
   extraUtils = pkgs.runCommand "extra-utils"
     { buildInputs = [pkgs.nukeReferences];
       allowedReferences = [ "out" ]; # prevent accidents like glibc being included in the initrd
-      doublePatchelf = pkgs.stdenv.isArm;
     }
     ''
       set +o pipefail
@@ -111,9 +110,6 @@ let
           if ! test -L $i; then
               echo "patching $i..."
               patchelf --set-interpreter $out/lib/ld*.so.? --set-rpath $out/lib $i || true
-              if [ -n "$doublePatchelf" ]; then
-                  patchelf --set-interpreter $out/lib/ld*.so.? --set-rpath $out/lib $i || true
-              fi
           fi
       done