summary refs log tree commit diff
path: root/nixos/modules/system/boot/stage-1.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2016-02-02 17:25:18 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2016-02-02 19:59:27 +0100
commit901163c0c707d36323400394bf6e75adc4621e2f (patch)
treee90ad80411cb00e206f39eff2cd07ff2fac65fc3 /nixos/modules/system/boot/stage-1.nix
parenta5d5736692a742a066f06902d55286a40e392543 (diff)
downloadnixlib-901163c0c707d36323400394bf6e75adc4621e2f.tar
nixlib-901163c0c707d36323400394bf6e75adc4621e2f.tar.gz
nixlib-901163c0c707d36323400394bf6e75adc4621e2f.tar.bz2
nixlib-901163c0c707d36323400394bf6e75adc4621e2f.tar.lz
nixlib-901163c0c707d36323400394bf6e75adc4621e2f.tar.xz
nixlib-901163c0c707d36323400394bf6e75adc4621e2f.tar.zst
nixlib-901163c0c707d36323400394bf6e75adc4621e2f.zip
Split the initrd sshd support into a separate module
Also, drop boot.initrd.postEarlyDeviceCommands since preLVMCommands
should work fine.
Diffstat (limited to 'nixos/modules/system/boot/stage-1.nix')
-rw-r--r--nixos/modules/system/boot/stage-1.nix10
1 files changed, 1 insertions, 9 deletions
diff --git a/nixos/modules/system/boot/stage-1.nix b/nixos/modules/system/boot/stage-1.nix
index baa5bf6c69fd..98ef7ba024b4 100644
--- a/nixos/modules/system/boot/stage-1.nix
+++ b/nixos/modules/system/boot/stage-1.nix
@@ -199,7 +199,7 @@ let
     inherit (config.boot) resumeDevice devSize runSize;
 
     inherit (config.boot.initrd) checkJournalingFS
-      preLVMCommands preDeviceCommands postEarlyDeviceCommands postDeviceCommands postMountCommands kernelModules;
+      preLVMCommands preDeviceCommands postDeviceCommands postMountCommands kernelModules;
 
     resumeDevices = map (sd: if sd ? device then sd.device else "/dev/disk/by-label/${sd.label}")
                     (filter (sd: (sd ? label || hasPrefix "/dev/" sd.device) && !sd.randomEncryption) config.swapDevices);
@@ -318,14 +318,6 @@ in
       '';
     };
 
-    boot.initrd.postEarlyDeviceCommands = mkOption {
-      default = "";
-      type = types.lines;
-      description = ''
-        Shell commands to be executed early after creation of device nodes.
-      '';
-    };
-
     boot.initrd.postMountCommands = mkOption {
       default = "";
       type = types.lines;