summary refs log tree commit diff
path: root/nixos/modules/system/boot/stage-1.nix
diff options
context:
space:
mode:
authorSamuel Dionne-Riel <samuel@dionne-riel.com>2018-07-07 22:25:23 -0400
committerSamuel Dionne-Riel <samuel@dionne-riel.com>2018-07-07 22:25:23 -0400
commit4106de56d080761975c204215e75b5b632ae7397 (patch)
tree019250272248364efb3741ab02277e613ad00102 /nixos/modules/system/boot/stage-1.nix
parent14a9ca27e69e33ac8ffb708de08883f8079f954a (diff)
downloadnixlib-4106de56d080761975c204215e75b5b632ae7397.tar
nixlib-4106de56d080761975c204215e75b5b632ae7397.tar.gz
nixlib-4106de56d080761975c204215e75b5b632ae7397.tar.bz2
nixlib-4106de56d080761975c204215e75b5b632ae7397.tar.lz
nixlib-4106de56d080761975c204215e75b5b632ae7397.tar.xz
nixlib-4106de56d080761975c204215e75b5b632ae7397.tar.zst
nixlib-4106de56d080761975c204215e75b5b632ae7397.zip
stage-1: Fixes use of stripDirs.
Diffstat (limited to 'nixos/modules/system/boot/stage-1.nix')
-rw-r--r--nixos/modules/system/boot/stage-1.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/stage-1.nix b/nixos/modules/system/boot/stage-1.nix
index 6756f68cdf72..b6a7081b896c 100644
--- a/nixos/modules/system/boot/stage-1.nix
+++ b/nixos/modules/system/boot/stage-1.nix
@@ -164,7 +164,7 @@ let
 
       # Strip binaries further than normal.
       chmod -R u+w $out
-      stripDirs "lib bin" "-s"
+      stripDirs "$STRIP" "lib bin" "-s"
 
       # Run patchelf to make the programs refer to the copied libraries.
       find $out/bin $out/lib -type f | while read i; do