summary refs log tree commit diff
path: root/nixos/modules/system/boot/stage-1.nix
diff options
context:
space:
mode:
authorChristian Albrecht <christian.albrecht@mayflower.de>2017-06-25 16:03:30 +0200
committerFranz Pletz <fpletz@fnordicwalking.de>2017-06-26 09:15:44 +0200
commit358470763822d490fb36f8e5e3eca6f1e4c8378f (patch)
tree61ce3085f3627647913484a343baeb712d6556d8 /nixos/modules/system/boot/stage-1.nix
parent639b74e7bec3e743bd76b15d6ca8308e0c548cd6 (diff)
downloadnixlib-358470763822d490fb36f8e5e3eca6f1e4c8378f.tar
nixlib-358470763822d490fb36f8e5e3eca6f1e4c8378f.tar.gz
nixlib-358470763822d490fb36f8e5e3eca6f1e4c8378f.tar.bz2
nixlib-358470763822d490fb36f8e5e3eca6f1e4c8378f.tar.lz
nixlib-358470763822d490fb36f8e5e3eca6f1e4c8378f.tar.xz
nixlib-358470763822d490fb36f8e5e3eca6f1e4c8378f.tar.zst
nixlib-358470763822d490fb36f8e5e3eca6f1e4c8378f.zip
nixos/boot/stage-1: fix failing nixos-rebuild switch because of blkid output
old version of blkid used to output version information including libblkid version
when invoked with --help parameter

new version does not output libblkid version when invoked with --help parameter

fix is to invoke blkid with -V parameter to output version including libblkid in both cases
Diffstat (limited to 'nixos/modules/system/boot/stage-1.nix')
-rw-r--r--nixos/modules/system/boot/stage-1.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/stage-1.nix b/nixos/modules/system/boot/stage-1.nix
index 73608a0e27f2..02870878c0f3 100644
--- a/nixos/modules/system/boot/stage-1.nix
+++ b/nixos/modules/system/boot/stage-1.nix
@@ -135,7 +135,7 @@ let
       $out/bin/ash -c 'echo hello world' | grep "hello world"
       export LD_LIBRARY_PATH=$out/lib
       $out/bin/mount --help 2>&1 | grep -q "BusyBox"
-      $out/bin/blkid --help 2>&1 | grep -q 'libblkid'
+      $out/bin/blkid -V 2>&1 | grep -q 'libblkid'
       $out/bin/udevadm --version
       $out/bin/dmsetup --version 2>&1 | tee -a log | grep -q "version:"
       LVM_SYSTEM_DIR=$out $out/bin/lvm version 2>&1 | tee -a log | grep -q "LVM"