summary refs log tree commit diff
path: root/nixos/modules/system/boot/resolved.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2015-05-11 15:54:16 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2015-07-22 12:23:45 +0200
commit6bd4e0b8cd8a5f043492846d7ee4531349962102 (patch)
tree57ffa0b5a08410d4bea68cb85ea3ffe1e0f3af6f /nixos/modules/system/boot/resolved.nix
parent65700b435c8a495e5ff7071e41db34bf49b9ef89 (diff)
downloadnixlib-6bd4e0b8cd8a5f043492846d7ee4531349962102.tar
nixlib-6bd4e0b8cd8a5f043492846d7ee4531349962102.tar.gz
nixlib-6bd4e0b8cd8a5f043492846d7ee4531349962102.tar.bz2
nixlib-6bd4e0b8cd8a5f043492846d7ee4531349962102.tar.lz
nixlib-6bd4e0b8cd8a5f043492846d7ee4531349962102.tar.xz
nixlib-6bd4e0b8cd8a5f043492846d7ee4531349962102.tar.zst
nixlib-6bd4e0b8cd8a5f043492846d7ee4531349962102.zip
Create systemd-{network,resolve} user/group unconditionally
This shuts up this error from dbus:

May 11 13:52:16 machine dbus-daemon[259]: Unknown username "systemd-network" in message bus configuration file
May 11 13:52:16 machine dbus-daemon[259]: Unknown username "systemd-resolve" in message bus configuration file

which happens because the D-Bus config for networkd/resolved is
enabled unconditionally, and we don't have an easy way to turn it off.

(cherry picked from commit f19b58fb6a5cc55af6d8d8ca7979f8e64255d2d0)
Diffstat (limited to 'nixos/modules/system/boot/resolved.nix')
-rw-r--r--nixos/modules/system/boot/resolved.nix3
1 files changed, 0 insertions, 3 deletions
diff --git a/nixos/modules/system/boot/resolved.nix b/nixos/modules/system/boot/resolved.nix
index ecd547322d3c..5a98b9b6d480 100644
--- a/nixos/modules/system/boot/resolved.nix
+++ b/nixos/modules/system/boot/resolved.nix
@@ -30,9 +30,6 @@ with lib;
       DNS=${concatStringsSep " " config.networking.nameservers}
     '';
 
-    users.extraUsers.systemd-resolve.uid = config.ids.uids.systemd-resolve;
-    users.extraGroups.systemd-resolve.gid = config.ids.gids.systemd-resolve;
-
   };
 
 }