summary refs log tree commit diff
path: root/nixos/modules/system/boot/plymouth.nix
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2016-07-18 13:42:26 +0300
committerNikolay Amiantov <ab@fmap.me>2016-07-18 13:45:37 +0300
commit9cab592abd816740f263162be31136177d6a3e92 (patch)
tree4b95073e93233eedf74fe56673f3c8a77c33de6b /nixos/modules/system/boot/plymouth.nix
parent86ad25625f7fb6867e515cb09d1da40834f75a9a (diff)
downloadnixlib-9cab592abd816740f263162be31136177d6a3e92.tar
nixlib-9cab592abd816740f263162be31136177d6a3e92.tar.gz
nixlib-9cab592abd816740f263162be31136177d6a3e92.tar.bz2
nixlib-9cab592abd816740f263162be31136177d6a3e92.tar.lz
nixlib-9cab592abd816740f263162be31136177d6a3e92.tar.xz
nixlib-9cab592abd816740f263162be31136177d6a3e92.tar.zst
nixlib-9cab592abd816740f263162be31136177d6a3e92.zip
plymouth service: style fixes
Diffstat (limited to 'nixos/modules/system/boot/plymouth.nix')
-rw-r--r--nixos/modules/system/boot/plymouth.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/plymouth.nix b/nixos/modules/system/boot/plymouth.nix
index 82c1032937c6..1d4d52750e00 100644
--- a/nixos/modules/system/boot/plymouth.nix
+++ b/nixos/modules/system/boot/plymouth.nix
@@ -112,6 +112,7 @@ in
       sed -i '/loginctl/d' $out/71-seat.rules
     '';
 
+    # We use `mkAfter` to ensure that LUKS password prompt would be shown earlier than the splash screen.
     boot.initrd.preLVMCommands = mkAfter ''
       mkdir -p /etc/plymouth
       ln -s ${configFile} /etc/plymouth/plymouthd.conf
@@ -121,7 +122,7 @@ in
       ln -s $extraUtils/lib/plymouth /etc/plymouth/plugins
 
       plymouthd --mode=boot --pid-file=/run/plymouth/pid --attach-to-session
-      plymouth --show-splash
+      plymouth show-splash
     '';
 
   };