summary refs log tree commit diff
path: root/nixos/modules/system/boot/plymouth.nix
diff options
context:
space:
mode:
authorMichael Peyton Jones <me@michaelpj.com>2017-12-11 20:42:00 +0000
committerMichael Peyton Jones <me@michaelpj.com>2017-12-11 20:42:00 +0000
commit638d24950dabafd6221a1c015df0db568c1ece5c (patch)
tree815da0ba474bc677d98190d7ed6512c4f67caa5b /nixos/modules/system/boot/plymouth.nix
parent3eccd0b11d176489d69c778f2fcb544438f3ab56 (diff)
downloadnixlib-638d24950dabafd6221a1c015df0db568c1ece5c.tar
nixlib-638d24950dabafd6221a1c015df0db568c1ece5c.tar.gz
nixlib-638d24950dabafd6221a1c015df0db568c1ece5c.tar.bz2
nixlib-638d24950dabafd6221a1c015df0db568c1ece5c.tar.lz
nixlib-638d24950dabafd6221a1c015df0db568c1ece5c.tar.xz
nixlib-638d24950dabafd6221a1c015df0db568c1ece5c.tar.zst
nixlib-638d24950dabafd6221a1c015df0db568c1ece5c.zip
plymouth: add breeze-plymouth as default theme
Diffstat (limited to 'nixos/modules/system/boot/plymouth.nix')
-rw-r--r--nixos/modules/system/boot/plymouth.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/nixos/modules/system/boot/plymouth.nix b/nixos/modules/system/boot/plymouth.nix
index 4b0c498424b5..e78fdf1311d3 100644
--- a/nixos/modules/system/boot/plymouth.nix
+++ b/nixos/modules/system/boot/plymouth.nix
@@ -8,9 +8,14 @@ let
 
   cfg = config.boot.plymouth;
 
+  breezePlymouth = pkgs.breeze-plymouth.override {
+    nixosBranding = true;
+    nixosVersion = config.system.nixosRelease;
+  };
+
   themesEnv = pkgs.buildEnv {
     name = "plymouth-themes";
-    paths = [ plymouth ] ++ cfg.themePackages;
+    paths = [ plymouth breezePlymouth ] ++ cfg.themePackages;
   };
 
   configFile = pkgs.writeText "plymouthd.conf" ''
@@ -38,7 +43,7 @@ in
       };
 
       theme = mkOption {
-        default = "fade-in";
+        default = "breeze";
         type = types.str;
         description = ''
           Splash screen theme.