summary refs log tree commit diff
path: root/nixos/modules/system/boot/networkd.nix
diff options
context:
space:
mode:
authorFlorian Jacob <projects+git@florianjacob.de>2017-07-05 13:48:18 +0200
committerFlorian Jacob <projects+git@florianjacob.de>2017-07-05 13:48:18 +0200
commitcd8a1a7ceb373a3bcf7894827a6e2e6bf39d0295 (patch)
tree33d2501e7363fa1cde31e2216d19730026fea62a /nixos/modules/system/boot/networkd.nix
parenta5a98f98a05ed73d45e52b9409b8a494d9ce072a (diff)
downloadnixlib-cd8a1a7ceb373a3bcf7894827a6e2e6bf39d0295.tar
nixlib-cd8a1a7ceb373a3bcf7894827a6e2e6bf39d0295.tar.gz
nixlib-cd8a1a7ceb373a3bcf7894827a6e2e6bf39d0295.tar.bz2
nixlib-cd8a1a7ceb373a3bcf7894827a6e2e6bf39d0295.tar.lz
nixlib-cd8a1a7ceb373a3bcf7894827a6e2e6bf39d0295.tar.xz
nixlib-cd8a1a7ceb373a3bcf7894827a6e2e6bf39d0295.tar.zst
nixlib-cd8a1a7ceb373a3bcf7894827a6e2e6bf39d0295.zip
networkd: Allow new MulticastDNS setting
which gained an implementation in systemd v233
Diffstat (limited to 'nixos/modules/system/boot/networkd.nix')
-rw-r--r--nixos/modules/system/boot/networkd.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/networkd.nix b/nixos/modules/system/boot/networkd.nix
index f96dde153610..b151b5688928 100644
--- a/nixos/modules/system/boot/networkd.nix
+++ b/nixos/modules/system/boot/networkd.nix
@@ -94,7 +94,7 @@ let
   checkNetwork = checkUnitConfig "Network" [
     (assertOnlyFields [
       "Description" "DHCP" "DHCPServer" "IPForward" "IPMasquerade" "IPv4LL" "IPv4LLRoute"
-      "LLMNR" "Domains" "Bridge" "Bond"
+      "LLMNR" "MulticastDNS" "Domains" "Bridge" "Bond"
     ])
     (assertValueOneOf "DHCP" ["both" "none" "v4" "v6"])
     (assertValueOneOf "DHCPServer" boolValues)
@@ -103,6 +103,7 @@ let
     (assertValueOneOf "IPv4LL" boolValues)
     (assertValueOneOf "IPv4LLRoute" boolValues)
     (assertValueOneOf "LLMNR" boolValues)
+    (assertValueOneOf "MulticastDNS" boolValues)
   ];
 
   checkAddress = checkUnitConfig "Address" [