summary refs log tree commit diff
path: root/nixos/modules/system/boot/networkd.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2017-02-03 02:20:47 +0100
committerProfpatsch <mail@profpatsch.de>2017-02-16 21:24:40 +0100
commitbb797c1390971753f17f33882cfd477bc0f6d186 (patch)
tree09bdf217bc75c498a743d3293a300ca6f97d7296 /nixos/modules/system/boot/networkd.nix
parent9debdaf512bc510f7f5d5450c4902e7d1f713274 (diff)
downloadnixlib-bb797c1390971753f17f33882cfd477bc0f6d186.tar
nixlib-bb797c1390971753f17f33882cfd477bc0f6d186.tar.gz
nixlib-bb797c1390971753f17f33882cfd477bc0f6d186.tar.bz2
nixlib-bb797c1390971753f17f33882cfd477bc0f6d186.tar.lz
nixlib-bb797c1390971753f17f33882cfd477bc0f6d186.tar.xz
nixlib-bb797c1390971753f17f33882cfd477bc0f6d186.tar.zst
nixlib-bb797c1390971753f17f33882cfd477bc0f6d186.zip
networking.networkd: adjust autmatic mapping of bonds
Since the bonds interface changed to a lot more possible values we create a
mapping of kernel bond attribute names and values to networkd attributes.
Those match for the most part, but have to transformed slightly.

There is also an assert that unknown options won’t slip through silently.
Diffstat (limited to 'nixos/modules/system/boot/networkd.nix')
-rw-r--r--nixos/modules/system/boot/networkd.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/networkd.nix b/nixos/modules/system/boot/networkd.nix
index be70bdbf0a91..f96dde153610 100644
--- a/nixos/modules/system/boot/networkd.nix
+++ b/nixos/modules/system/boot/networkd.nix
@@ -79,7 +79,7 @@ let
   checkBond = checkUnitConfig "Bond" [
     (assertOnlyFields [
       "Mode" "TransmitHashPolicy" "LACPTransmitRate" "MIIMonitorSec"
-      "UpDelaySec" "DownDelaySec"
+      "UpDelaySec" "DownDelaySec" "GratuitousARP"
     ])
     (assertValueOneOf "Mode" [
       "balance-rr" "active-backup" "balance-xor"