summary refs log tree commit diff
path: root/nixos/modules/system/boot/networkd.nix
diff options
context:
space:
mode:
authorAlexander Shpilkin <ashpilkin@gmail.com>2018-09-07 02:01:21 +0300
committerAlexander Shpilkin <ashpilkin@gmail.com>2018-09-07 02:01:21 +0300
commit8fdb6fba30a22c15bd86fb756a49559b9e5d590c (patch)
treef10c5142582579450718594aaa37db2e0916650a /nixos/modules/system/boot/networkd.nix
parent423e46a24f240a6e9a6ddcb788db51989f57eb58 (diff)
downloadnixlib-8fdb6fba30a22c15bd86fb756a49559b9e5d590c.tar
nixlib-8fdb6fba30a22c15bd86fb756a49559b9e5d590c.tar.gz
nixlib-8fdb6fba30a22c15bd86fb756a49559b9e5d590c.tar.bz2
nixlib-8fdb6fba30a22c15bd86fb756a49559b9e5d590c.tar.lz
nixlib-8fdb6fba30a22c15bd86fb756a49559b9e5d590c.tar.xz
nixlib-8fdb6fba30a22c15bd86fb756a49559b9e5d590c.tar.zst
nixlib-8fdb6fba30a22c15bd86fb756a49559b9e5d590c.zip
nixos/networkd: fix handling of RequiredForOnline
Diffstat (limited to 'nixos/modules/system/boot/networkd.nix')
-rw-r--r--nixos/modules/system/boot/networkd.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/networkd.nix b/nixos/modules/system/boot/networkd.nix
index 8e748dd27d7d..5f1de572e5b1 100644
--- a/nixos/modules/system/boot/networkd.nix
+++ b/nixos/modules/system/boot/networkd.nix
@@ -256,7 +256,7 @@ let
     (assertValueOneOf "ARP" boolValues)
     (assertValueOneOf "Multicast" boolValues)
     (assertValueOneOf "Unmanaged" boolValues)
-    (assertValueOneOf "RquiredForOnline" boolValues)
+    (assertValueOneOf "RequiredForOnline" boolValues)
   ];