summary refs log tree commit diff
path: root/nixos/modules/system/boot/networkd.nix
diff options
context:
space:
mode:
authorBen Gamari <ben@smart-cactus.org>2018-04-27 16:39:45 +0000
committerBen Gamari <ben@smart-cactus.org>2018-04-27 16:41:16 +0000
commit65c1cfce3f72436a3a9fcba8053f6a7a5c6e078e (patch)
treec33d4ccfe92ee08aca41ab5ced0d4a7a229bc9ba /nixos/modules/system/boot/networkd.nix
parentbea11a34fbcefe24a66cf64c7388124db567a17d (diff)
downloadnixlib-65c1cfce3f72436a3a9fcba8053f6a7a5c6e078e.tar
nixlib-65c1cfce3f72436a3a9fcba8053f6a7a5c6e078e.tar.gz
nixlib-65c1cfce3f72436a3a9fcba8053f6a7a5c6e078e.tar.bz2
nixlib-65c1cfce3f72436a3a9fcba8053f6a7a5c6e078e.tar.lz
nixlib-65c1cfce3f72436a3a9fcba8053f6a7a5c6e078e.tar.xz
nixlib-65c1cfce3f72436a3a9fcba8053f6a7a5c6e078e.tar.zst
nixlib-65c1cfce3f72436a3a9fcba8053f6a7a5c6e078e.zip
nixos/networkd: Allow RequiredForOnline field in [Link] section
This was previously missing.
Diffstat (limited to 'nixos/modules/system/boot/networkd.nix')
-rw-r--r--nixos/modules/system/boot/networkd.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/networkd.nix b/nixos/modules/system/boot/networkd.nix
index eea10613ea58..e95ca27914ec 100644
--- a/nixos/modules/system/boot/networkd.nix
+++ b/nixos/modules/system/boot/networkd.nix
@@ -146,12 +146,13 @@ let
   # .network files have a [Link] section with different options than in .netlink files
   checkNetworkLink = checkUnitConfig "Link" [
     (assertOnlyFields [
-      "MACAddress" "MTUBytes" "ARP" "Unmanaged"
+      "MACAddress" "MTUBytes" "ARP" "Unmanaged" "RequiredForOnline"
     ])
     (assertMacAddress "MACAddress")
     (assertByteFormat "MTUBytes")
     (assertValueOneOf "ARP" boolValues)
     (assertValueOneOf "Unmanaged" boolValues)
+    (assertValueOneOf "RquiredForOnline" boolValues)
   ];