summary refs log tree commit diff
path: root/nixos/modules/system/boot/modprobe.nix
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2014-01-21 00:29:35 +0100
committerVladimír Čunát <vcunat@gmail.com>2014-01-28 12:52:36 +0100
commit5acaa980a510f77fce358bdbe93ab5fa388118fd (patch)
treec407cf2ccba52f91f085a9c70256c320b0d60d78 /nixos/modules/system/boot/modprobe.nix
parent849b383f4d26eed9145fe2b584d1cf3d6f7dd63a (diff)
downloadnixlib-5acaa980a510f77fce358bdbe93ab5fa388118fd.tar
nixlib-5acaa980a510f77fce358bdbe93ab5fa388118fd.tar.gz
nixlib-5acaa980a510f77fce358bdbe93ab5fa388118fd.tar.bz2
nixlib-5acaa980a510f77fce358bdbe93ab5fa388118fd.tar.lz
nixlib-5acaa980a510f77fce358bdbe93ab5fa388118fd.tar.xz
nixlib-5acaa980a510f77fce358bdbe93ab5fa388118fd.tar.zst
nixlib-5acaa980a510f77fce358bdbe93ab5fa388118fd.zip
pull module blacklist from Ubuntu and use it by default
People often have serious problems due to bogus modules like *fb.
Diffstat (limited to 'nixos/modules/system/boot/modprobe.nix')
-rw-r--r--nixos/modules/system/boot/modprobe.nix24
1 files changed, 6 insertions, 18 deletions
diff --git a/nixos/modules/system/boot/modprobe.nix b/nixos/modules/system/boot/modprobe.nix
index 027a7ac99d51..f694fd29dd04 100644
--- a/nixos/modules/system/boot/modprobe.nix
+++ b/nixos/modules/system/boot/modprobe.nix
@@ -68,7 +68,10 @@ with pkgs.lib;
 
   config = mkIf (!config.boot.isContainer) {
 
-    environment.etc = singleton
+    environment.etc = [
+      { source = "${pkgs.kmod-blacklist-ubuntu}/modprobe.conf";
+        target = "modprobe.d/ubuntu.conf";
+      }
       { source = pkgs.writeText "modprobe.conf"
           ''
             ${flip concatMapStrings config.boot.blacklistedKernelModules (name: ''
@@ -77,26 +80,11 @@ with pkgs.lib;
             ${config.boot.extraModprobeConfig}
           '';
         target = "modprobe.d/nixos.conf";
-      };
+      }
+    ];
 
     environment.systemPackages = [ config.system.sbin.modprobe pkgs.kmod ];
 
-    boot.blacklistedKernelModules =
-      [ # This module is for debugging and generates gigantic amounts
-        # of log output, so it should never be loaded automatically.
-        "evbug"
-
-        # This module causes ALSA to occassionally select the wrong
-        # default sound device, and is little more than an annoyance
-        # on modern machines.
-        "snd_pcsp"
-
-        # The cirrusfb module prevents X11 from starting.  FIXME:
-        # Ubuntu blacklists all framebuffer devices because they're
-        # "buggy" and cause suspend problems.  Maybe we should too?
-        "cirrusfb"
-      ];
-
     system.activationScripts.modprobe =
       ''
         # Allow the kernel to find our wrapped modprobe (which searches