summary refs log tree commit diff
path: root/nixos/modules/system/boot/luksroot.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-23 18:22:26 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-23 20:08:22 +0200
commit8f4c5b05d5639c1577ce92c9e42a5d59b8be4cda (patch)
tree73bac7d9a21a4e95f74d462faf7cfdcd2bc78c55 /nixos/modules/system/boot/luksroot.nix
parentb5d5afd99a7ff24de036885364f7a7bbe90dd405 (diff)
downloadnixlib-8f4c5b05d5639c1577ce92c9e42a5d59b8be4cda.tar
nixlib-8f4c5b05d5639c1577ce92c9e42a5d59b8be4cda.tar.gz
nixlib-8f4c5b05d5639c1577ce92c9e42a5d59b8be4cda.tar.bz2
nixlib-8f4c5b05d5639c1577ce92c9e42a5d59b8be4cda.tar.lz
nixlib-8f4c5b05d5639c1577ce92c9e42a5d59b8be4cda.tar.xz
nixlib-8f4c5b05d5639c1577ce92c9e42a5d59b8be4cda.tar.zst
nixlib-8f4c5b05d5639c1577ce92c9e42a5d59b8be4cda.zip
Add a way to define obsolete options that have no replacement
Diffstat (limited to 'nixos/modules/system/boot/luksroot.nix')
-rw-r--r--nixos/modules/system/boot/luksroot.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nixos/modules/system/boot/luksroot.nix b/nixos/modules/system/boot/luksroot.nix
index 29f5eb4fd771..ba357f5d2de3 100644
--- a/nixos/modules/system/boot/luksroot.nix
+++ b/nixos/modules/system/boot/luksroot.nix
@@ -44,12 +44,9 @@ in
 {
 
   options = {
-    boot.initrd.luks.enable = mkOption {
-      default = false;
-      description = "Obsolete.";
-    };
 
     boot.initrd.luks.mitigateDMAAttacks = mkOption {
+      type = types.bool;
       default = true;
       description = ''
         Unless enabled, encryption keys can be easily recovered by an attacker with physical
@@ -62,6 +59,7 @@ in
     };
 
     boot.initrd.luks.cryptoModules = mkOption {
+      type = types.listOf types.string;
       default =
         [ "aes" "aes_generic" "blowfish" "twofish"
           "serpent" "cbc" "xts" "lrw" "sha1" "sha256" "sha512"
@@ -142,7 +140,9 @@ in
         };
 
       };
+
     };
+
   };
 
   config = mkIf (luks.devices != []) {