summary refs log tree commit diff
path: root/nixos/modules/system/boot/loader/loader.nix
diff options
context:
space:
mode:
authorBob van der Linden <bobvanderlinden@gmail.com>2015-01-14 20:35:54 +0100
committerLuca Bruno <lethalman88@gmail.com>2015-01-30 09:53:44 +0100
commitf93ba5146954a98a3ba132ebd1cd81f04ba01fe4 (patch)
tree68d5737dae79a0d861e1254a215f5aba9cab28c0 /nixos/modules/system/boot/loader/loader.nix
parentdb75b5d052f67ffdda7232ab032161343e8cca59 (diff)
downloadnixlib-f93ba5146954a98a3ba132ebd1cd81f04ba01fe4.tar
nixlib-f93ba5146954a98a3ba132ebd1cd81f04ba01fe4.tar.gz
nixlib-f93ba5146954a98a3ba132ebd1cd81f04ba01fe4.tar.bz2
nixlib-f93ba5146954a98a3ba132ebd1cd81f04ba01fe4.tar.lz
nixlib-f93ba5146954a98a3ba132ebd1cd81f04ba01fe4.tar.xz
nixlib-f93ba5146954a98a3ba132ebd1cd81f04ba01fe4.tar.zst
nixlib-f93ba5146954a98a3ba132ebd1cd81f04ba01fe4.zip
nixos: loader: added generic config.boot.loader.timeout option
timeout options of grub and gummiboot will inherit the value of this
option by default.
Diffstat (limited to 'nixos/modules/system/boot/loader/loader.nix')
-rw-r--r--nixos/modules/system/boot/loader/loader.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/nixos/modules/system/boot/loader/loader.nix b/nixos/modules/system/boot/loader/loader.nix
new file mode 100644
index 000000000000..28cceafea7ca
--- /dev/null
+++ b/nixos/modules/system/boot/loader/loader.nix
@@ -0,0 +1,15 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+    options = {
+        boot.loader.timeout =  mkOption {
+            default = 5;
+            type = types.nullOr types.int;
+            description = ''
+              Timeout (in seconds) until loader boots the default menu item. Use null if the loader menu should be displayed indefinitely.
+            '';
+        };
+    };
+}
\ No newline at end of file