summary refs log tree commit diff
path: root/nixos/modules/system/boot/loader/grub/grub.nix
diff options
context:
space:
mode:
authorLuca Bruno <lethalman88@gmail.com>2015-01-30 10:36:26 +0100
committerLuca Bruno <lethalman88@gmail.com>2015-01-30 10:39:50 +0100
commita239775488722bc8325e9d5bdfefd20bfab38164 (patch)
treedca13b21ae6fcf0c2069f3f0055e39633db56202 /nixos/modules/system/boot/loader/grub/grub.nix
parent3c7e1ef6980e38bb2efe0c2593d99fb3ee8a7804 (diff)
parenta3d5f4f3efe51a13cece90d51284f85033fcbc28 (diff)
downloadnixlib-a239775488722bc8325e9d5bdfefd20bfab38164.tar
nixlib-a239775488722bc8325e9d5bdfefd20bfab38164.tar.gz
nixlib-a239775488722bc8325e9d5bdfefd20bfab38164.tar.bz2
nixlib-a239775488722bc8325e9d5bdfefd20bfab38164.tar.lz
nixlib-a239775488722bc8325e9d5bdfefd20bfab38164.tar.xz
nixlib-a239775488722bc8325e9d5bdfefd20bfab38164.tar.zst
nixlib-a239775488722bc8325e9d5bdfefd20bfab38164.zip
Merge PR #5772, boot.loader.timeout
Diffstat (limited to 'nixos/modules/system/boot/loader/grub/grub.nix')
-rw-r--r--nixos/modules/system/boot/loader/grub/grub.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/loader/grub/grub.nix b/nixos/modules/system/boot/loader/grub/grub.nix
index 3ea00e40c3b3..b16a725aba8e 100644
--- a/nixos/modules/system/boot/loader/grub/grub.nix
+++ b/nixos/modules/system/boot/loader/grub/grub.nix
@@ -196,7 +196,7 @@ in
       };
 
       timeout = mkOption {
-        default = 5;
+        default = if (config.boot.loader.timeout != null) then config.boot.loader.timeout else -1;
         type = types.int;
         description = ''
           Timeout (in seconds) until GRUB boots the default menu item.