summary refs log tree commit diff
path: root/nixos/modules/system/boot/loader/grub/grub.nix
diff options
context:
space:
mode:
authorsymphorien <symphorien@users.noreply.github.com>2017-02-13 14:53:15 +0100
committerRobin Gloster <mail@glob.in>2017-02-13 14:53:15 +0100
commit0b87efacb14425f65e75c489e26b21952ece805c (patch)
treed096cfbd3ec3c079d1dfd212b902dc4694614485 /nixos/modules/system/boot/loader/grub/grub.nix
parent5d00edcf4f018d80dbed9e55e431d2054faf7078 (diff)
downloadnixlib-0b87efacb14425f65e75c489e26b21952ece805c.tar
nixlib-0b87efacb14425f65e75c489e26b21952ece805c.tar.gz
nixlib-0b87efacb14425f65e75c489e26b21952ece805c.tar.bz2
nixlib-0b87efacb14425f65e75c489e26b21952ece805c.tar.lz
nixlib-0b87efacb14425f65e75c489e26b21952ece805c.tar.xz
nixlib-0b87efacb14425f65e75c489e26b21952ece805c.tar.zst
nixlib-0b87efacb14425f65e75c489e26b21952ece805c.zip
grub: add grub.useOSProber option (#22558)
Diffstat (limited to 'nixos/modules/system/boot/loader/grub/grub.nix')
-rw-r--r--nixos/modules/system/boot/loader/grub/grub.nix14
1 files changed, 12 insertions, 2 deletions
diff --git a/nixos/modules/system/boot/loader/grub/grub.nix b/nixos/modules/system/boot/loader/grub/grub.nix
index 294fc1988e9f..23b970186a39 100644
--- a/nixos/modules/system/boot/loader/grub/grub.nix
+++ b/nixos/modules/system/boot/loader/grub/grub.nix
@@ -53,12 +53,14 @@ let
       inherit (args) devices;
       inherit (efi) canTouchEfiVariables;
       inherit (cfg)
-        version extraConfig extraPerEntryConfig extraEntries forceInstall 
+        version extraConfig extraPerEntryConfig extraEntries forceInstall useOSProber
         extraEntriesBeforeNixOS extraPrepareConfig configurationLimit copyKernels
         default fsIdentifier efiSupport efiInstallAsRemovable gfxmodeEfi gfxmodeBios;
       path = (makeBinPath ([
         pkgs.coreutils pkgs.gnused pkgs.gnugrep pkgs.findutils pkgs.diffutils pkgs.btrfs-progs
-        pkgs.utillinux ] ++ (if cfg.efiSupport && (cfg.version == 2) then [pkgs.efibootmgr ] else [])
+        pkgs.utillinux ]
+        ++ (optional (cfg.efiSupport && (cfg.version == 2)) pkgs.efibootmgr)
+        ++ (optionals cfg.useOSProber [pkgs.busybox pkgs.os-prober])
       )) + ":" + (makeSearchPathOutput "bin" "sbin" [
         pkgs.mdadm pkgs.utillinux
       ]);
@@ -265,6 +267,14 @@ in
         '';
       };
 
+      useOSProber = mkOption {
+        default = false;
+        type = types.bool;
+        description = ''
+          If set to true, append entries for other OSs detected by os-prober.
+        '';
+      };
+
       splashImage = mkOption {
         type = types.nullOr types.path;
         example = literalExample "./my-background.png";