summary refs log tree commit diff
path: root/nixos/modules/system/boot/kexec.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2018-03-25 17:45:22 -0400
committerShea Levy <shea@shealevy.com>2018-03-27 08:15:07 -0400
commitcdf9a78a3ebb535fa6ba88fce88c655776d2474f (patch)
tree494af986a0c2adc37a3c6d1173a0dc563ae96174 /nixos/modules/system/boot/kexec.nix
parentb0482248fefbf3b6cdd9c92053cfb49778a3a3a8 (diff)
downloadnixlib-cdf9a78a3ebb535fa6ba88fce88c655776d2474f.tar
nixlib-cdf9a78a3ebb535fa6ba88fce88c655776d2474f.tar.gz
nixlib-cdf9a78a3ebb535fa6ba88fce88c655776d2474f.tar.bz2
nixlib-cdf9a78a3ebb535fa6ba88fce88c655776d2474f.tar.lz
nixlib-cdf9a78a3ebb535fa6ba88fce88c655776d2474f.tar.xz
nixlib-cdf9a78a3ebb535fa6ba88fce88c655776d2474f.tar.zst
nixlib-cdf9a78a3ebb535fa6ba88fce88c655776d2474f.zip
kexectools: Disable only on RISC-V if Linux.
The isKexecable flag treated Linux without kexec as just a normal
variant, when it really should be treated as a special case incurring
complexity debt to support.
Diffstat (limited to 'nixos/modules/system/boot/kexec.nix')
-rw-r--r--nixos/modules/system/boot/kexec.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/kexec.nix b/nixos/modules/system/boot/kexec.nix
index 14ebe66e6320..3fc1af28f628 100644
--- a/nixos/modules/system/boot/kexec.nix
+++ b/nixos/modules/system/boot/kexec.nix
@@ -1,7 +1,7 @@
 { config, pkgs, lib, ... }:
 
 {
-  config = lib.mkIf (pkgs.kexectools != null) {
+  config = lib.mkIf (pkgs.kexectools.meta.available) {
     environment.systemPackages = [ pkgs.kexectools ];
 
     systemd.services."prepare-kexec" =