summary refs log tree commit diff
path: root/nixos/modules/system/boot/kexec.nix
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas.tynkkynen@iki.fi>2018-08-29 01:21:33 +0300
committerTuomas Tynkkynen <tuomas.tynkkynen@iki.fi>2018-09-28 15:01:00 +0300
commit599c4df46a90c7415a6cc0689f0b23d22e7fdb67 (patch)
treecda6d3b7556eab072c8eadf08c6b4d10273ea75e /nixos/modules/system/boot/kexec.nix
parentf4dd2fed7f57782fae0b3c9c9226effc5185ab7d (diff)
downloadnixlib-599c4df46a90c7415a6cc0689f0b23d22e7fdb67.tar
nixlib-599c4df46a90c7415a6cc0689f0b23d22e7fdb67.tar.gz
nixlib-599c4df46a90c7415a6cc0689f0b23d22e7fdb67.tar.bz2
nixlib-599c4df46a90c7415a6cc0689f0b23d22e7fdb67.tar.lz
nixlib-599c4df46a90c7415a6cc0689f0b23d22e7fdb67.tar.xz
nixlib-599c4df46a90c7415a6cc0689f0b23d22e7fdb67.tar.zst
nixlib-599c4df46a90c7415a6cc0689f0b23d22e7fdb67.zip
nixos/kexec: Replace meta.available checks
This sort of code breaks config.{allowBroken, allowUnsupportedSystem} =
true by making them do unpredictable things.
Diffstat (limited to 'nixos/modules/system/boot/kexec.nix')
-rw-r--r--nixos/modules/system/boot/kexec.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/kexec.nix b/nixos/modules/system/boot/kexec.nix
index 3e5d7b40f2c5..b95673d825b3 100644
--- a/nixos/modules/system/boot/kexec.nix
+++ b/nixos/modules/system/boot/kexec.nix
@@ -1,7 +1,7 @@
 { pkgs, lib, ... }:
 
 {
-  config = lib.mkIf (pkgs.kexectools.meta.available) {
+  config = lib.mkIf (lib.any (lib.meta.platformMatch pkgs.stdenv.hostPlatform) pkgs.kexectools.meta.platform) {
     environment.systemPackages = [ pkgs.kexectools ];
 
     systemd.services."prepare-kexec" =