summary refs log tree commit diff
path: root/nixos/modules/system/boot/kernel.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2016-01-07 12:48:12 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2016-01-07 13:20:53 +0100
commite4b4e9b9866758d7843cafe941cb7b59132bd673 (patch)
tree3941aa6e13b9bc742af766e50286a522e987d0e7 /nixos/modules/system/boot/kernel.nix
parent48e66c39257526a94986ea24c1baa2b7e00835ee (diff)
downloadnixlib-e4b4e9b9866758d7843cafe941cb7b59132bd673.tar
nixlib-e4b4e9b9866758d7843cafe941cb7b59132bd673.tar.gz
nixlib-e4b4e9b9866758d7843cafe941cb7b59132bd673.tar.bz2
nixlib-e4b4e9b9866758d7843cafe941cb7b59132bd673.tar.lz
nixlib-e4b4e9b9866758d7843cafe941cb7b59132bd673.tar.xz
nixlib-e4b4e9b9866758d7843cafe941cb7b59132bd673.tar.zst
nixlib-e4b4e9b9866758d7843cafe941cb7b59132bd673.zip
linux: Make Unix domain sockets builtin
This hopefully fixes intermittent initrd failures where udevd cannot
create a Unix domain socket:

  machine# running udev...
  machine# error getting socket: Address family not supported by protocol
  machine# error initializing udev control socket
  machine# error getting socket: Address family not supported by protocol

The "unix" kernel module is supposed to be loaded automatically, and
clearly that works most of the time, but maybe there is a race
somewhere. In any case, no sane person would run a kernel without Unix
domain sockets, so we may as well make it builtin.

http://hydra.nixos.org/build/30001448
Diffstat (limited to 'nixos/modules/system/boot/kernel.nix')
-rw-r--r--nixos/modules/system/boot/kernel.nix3
1 files changed, 0 insertions, 3 deletions
diff --git a/nixos/modules/system/boot/kernel.nix b/nixos/modules/system/boot/kernel.nix
index 17e3a038221c..bef18fc8771b 100644
--- a/nixos/modules/system/boot/kernel.nix
+++ b/nixos/modules/system/boot/kernel.nix
@@ -197,9 +197,6 @@ in
         "hid_generic" "hid_lenovo"
         "hid_apple" "hid_logitech_dj" "hid_lenovo_tpkbd" "hid_roccat"
 
-        # Unix domain sockets (needed by udev).
-        "unix"
-
         # Misc. stuff.
         "pcips2" "atkbd"