summary refs log tree commit diff
path: root/nixos/modules/system/boot/kernel.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-11-27 16:54:20 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-11-27 17:14:10 +0100
commit9ee30cd9b51c46cea7193993d006bb4301588001 (patch)
treedf235eb03f6b5a8af7966868ad2faca60403e345 /nixos/modules/system/boot/kernel.nix
parent57f145a7f8c3bd01e5ac1927cb0e1b14658fa7aa (diff)
downloadnixlib-9ee30cd9b51c46cea7193993d006bb4301588001.tar
nixlib-9ee30cd9b51c46cea7193993d006bb4301588001.tar.gz
nixlib-9ee30cd9b51c46cea7193993d006bb4301588001.tar.bz2
nixlib-9ee30cd9b51c46cea7193993d006bb4301588001.tar.lz
nixlib-9ee30cd9b51c46cea7193993d006bb4301588001.tar.xz
nixlib-9ee30cd9b51c46cea7193993d006bb4301588001.tar.zst
nixlib-9ee30cd9b51c46cea7193993d006bb4301588001.zip
Add support for lightweight NixOS containers
You can now say:

  systemd.containers.foo.config =
    { services.openssh.enable = true;
      services.openssh.ports = [ 2022 ];
      users.extraUsers.root.openssh.authorizedKeys.keys = [ "ssh-dss ..." ];
    };

which defines a NixOS instance with the given configuration running
inside a lightweight container.

You can also manage the configuration of the container independently
from the host:

  systemd.containers.foo.path = "/nix/var/nix/profiles/containers/foo";

where "path" is a NixOS system profile.  It can be created/updated by
doing:

  $ nix-env --set -p /nix/var/nix/profiles/containers/foo \
      -f '<nixos>' -A system -I nixos-config=foo.nix

The container configuration (foo.nix) should define

  boot.isContainer = true;

to optimise away the building of a kernel and initrd.  This is done
automatically when using the "config" route.

On the host, a lightweight container appears as the service
"container-<name>.service".  The container is like a regular NixOS
(virtual) machine, except that it doesn't have its own kernel.  It has
its own root file system (by default /var/lib/containers/<name>), but
shares the Nix store of the host (as a read-only bind mount).  It also
has access to the network devices of the host.

Currently, if the configuration of the container changes, running
"nixos-rebuild switch" on the host will cause the container to be
rebooted.  In the future we may want to send some message to the
container so that it can activate the new container configuration
without rebooting.

Containers are not perfectly isolated yet.  In particular, the host's
/sys/fs/cgroup is mounted (writable!) in the guest.
Diffstat (limited to 'nixos/modules/system/boot/kernel.nix')
-rw-r--r--nixos/modules/system/boot/kernel.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/kernel.nix b/nixos/modules/system/boot/kernel.nix
index c3c38b186bdd..ee2f5e9b4f61 100644
--- a/nixos/modules/system/boot/kernel.nix
+++ b/nixos/modules/system/boot/kernel.nix
@@ -145,7 +145,7 @@ in
 
   ###### implementation
 
-  config = {
+  config = mkIf (!config.boot.isContainer) {
 
     system.build = { inherit kernel; };