summary refs log tree commit diff
path: root/nixos/modules/system/boot/kernel.nix
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2016-08-14 13:01:14 +0300
committerNikolay Amiantov <ab@fmap.me>2016-08-19 17:56:54 +0300
commit6b41f1132c0dab25d98a74c28aafdc524131d0f5 (patch)
tree45a72be534c565dc9d296c629546ced153e26f6b /nixos/modules/system/boot/kernel.nix
parent5ff6e98486adb1a3ff3f705bdc43216d3a885d73 (diff)
downloadnixlib-6b41f1132c0dab25d98a74c28aafdc524131d0f5.tar
nixlib-6b41f1132c0dab25d98a74c28aafdc524131d0f5.tar.gz
nixlib-6b41f1132c0dab25d98a74c28aafdc524131d0f5.tar.bz2
nixlib-6b41f1132c0dab25d98a74c28aafdc524131d0f5.tar.lz
nixlib-6b41f1132c0dab25d98a74c28aafdc524131d0f5.tar.xz
nixlib-6b41f1132c0dab25d98a74c28aafdc524131d0f5.tar.zst
nixlib-6b41f1132c0dab25d98a74c28aafdc524131d0f5.zip
nixos treewide: don't set MODULE_DIR
Diffstat (limited to 'nixos/modules/system/boot/kernel.nix')
-rw-r--r--nixos/modules/system/boot/kernel.nix5
1 files changed, 0 insertions, 5 deletions
diff --git a/nixos/modules/system/boot/kernel.nix b/nixos/modules/system/boot/kernel.nix
index a6bbca9b30bb..0f342f44fe76 100644
--- a/nixos/modules/system/boot/kernel.nix
+++ b/nixos/modules/system/boot/kernel.nix
@@ -228,7 +228,6 @@ in
     systemd.services."systemd-modules-load" =
       { wantedBy = [ "multi-user.target" ];
         restartTriggers = [ kernelModulesConf ];
-        environment.MODULE_DIR = "/run/booted-system/kernel-modules/lib/modules";
         serviceConfig =
           { # Ignore failed module loads.  Typically some of the
             # modules in ‘boot.kernelModules’ are "nice to have but
@@ -238,10 +237,6 @@ in
           };
       };
 
-    systemd.services.kmod-static-nodes =
-      { environment.MODULE_DIR = "/run/booted-system/kernel-modules/lib/modules";
-      };
-
     lib.kernelConfig = {
       isYes = option: {
         assertion = config: config.isYes option;