summary refs log tree commit diff
path: root/nixos/modules/system/boot/kernel.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-03-05 15:20:59 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-03-05 15:22:32 +0100
commit6572708d3914a07a1c58f6162b999925ee3d695e (patch)
tree41ee9553af6ee241293f550edb4ab00748a84bc3 /nixos/modules/system/boot/kernel.nix
parent97d291d040c5e85b88f6c2695123de01de13a5c4 (diff)
downloadnixlib-6572708d3914a07a1c58f6162b999925ee3d695e.tar
nixlib-6572708d3914a07a1c58f6162b999925ee3d695e.tar.gz
nixlib-6572708d3914a07a1c58f6162b999925ee3d695e.tar.bz2
nixlib-6572708d3914a07a1c58f6162b999925ee3d695e.tar.lz
nixlib-6572708d3914a07a1c58f6162b999925ee3d695e.tar.xz
nixlib-6572708d3914a07a1c58f6162b999925ee3d695e.tar.zst
nixlib-6572708d3914a07a1c58f6162b999925ee3d695e.zip
Always load the "configs" kernel module
We used to have the configuration of the kernel available in a
somewhat convenient place (/run/booted-system/kernel-modules/config)
but that has disappeared.  So instead just make /proc/configs.gz
available.  It only eats a few kilobytes.
Diffstat (limited to 'nixos/modules/system/boot/kernel.nix')
-rw-r--r--nixos/modules/system/boot/kernel.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/kernel.nix b/nixos/modules/system/boot/kernel.nix
index 2b075bf6a6d2..327f3b7e1128 100644
--- a/nixos/modules/system/boot/kernel.nix
+++ b/nixos/modules/system/boot/kernel.nix
@@ -159,7 +159,7 @@ in
 
     boot.kernel.sysctl."kernel.printk" = config.boot.consoleLogLevel;
 
-    boot.kernelModules = [ "loop" ];
+    boot.kernelModules = [ "loop" "configs" ];
 
     boot.initrd.availableKernelModules =
       [ # Note: most of these (especially the SATA/PATA modules)