summary refs log tree commit diff
path: root/nixos/modules/system/boot/kernel.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-11-26 18:17:12 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-11-26 18:19:45 +0100
commit2b1f21249445991940c9d3ebbc54ce41b1eaf9c0 (patch)
tree3c7f98ee825b69af81ba7215b6ef2489375e37b3 /nixos/modules/system/boot/kernel.nix
parentda093461a2ff09d6ea1071ff886866a1f85480c2 (diff)
downloadnixlib-2b1f21249445991940c9d3ebbc54ce41b1eaf9c0.tar
nixlib-2b1f21249445991940c9d3ebbc54ce41b1eaf9c0.tar.gz
nixlib-2b1f21249445991940c9d3ebbc54ce41b1eaf9c0.tar.bz2
nixlib-2b1f21249445991940c9d3ebbc54ce41b1eaf9c0.tar.lz
nixlib-2b1f21249445991940c9d3ebbc54ce41b1eaf9c0.tar.xz
nixlib-2b1f21249445991940c9d3ebbc54ce41b1eaf9c0.tar.zst
nixlib-2b1f21249445991940c9d3ebbc54ce41b1eaf9c0.zip
Disable various services when running inside a container
Diffstat (limited to 'nixos/modules/system/boot/kernel.nix')
-rw-r--r--nixos/modules/system/boot/kernel.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/kernel.nix b/nixos/modules/system/boot/kernel.nix
index 64d4c33c9655..c3c38b186bdd 100644
--- a/nixos/modules/system/boot/kernel.nix
+++ b/nixos/modules/system/boot/kernel.nix
@@ -231,7 +231,10 @@ in
         wantedBy = [ "sysinit.target" "multi-user.target" ];
         before = [ "sysinit.target" "shutdown.target" ];
         conflicts = [ "shutdown.target" ];
-        unitConfig.DefaultDependencies = "no";
+        unitConfig =
+          { DefaultDependencies = false;
+            ConditionCapability = "CAP_SYS_MODULE";
+          };
         serviceConfig =
           { Type = "oneshot";
             RemainAfterExit = true;