summary refs log tree commit diff
path: root/nixos/modules/system/boot/grow-partition.nix
diff options
context:
space:
mode:
authorzimbatm <zimbatm@zimbatm.com>2018-01-06 13:52:51 +0000
committerGitHub <noreply@github.com>2018-01-06 13:52:51 +0000
commiteddf30cc93e1b778b6bc10d0eb1bb175385d034f (patch)
treeb95f3a695c0794e674743e6551e47476a5b22ec6 /nixos/modules/system/boot/grow-partition.nix
parent51110e2a0fc9c415973b61adf09cd1dae16abff7 (diff)
downloadnixlib-eddf30cc93e1b778b6bc10d0eb1bb175385d034f.tar
nixlib-eddf30cc93e1b778b6bc10d0eb1bb175385d034f.tar.gz
nixlib-eddf30cc93e1b778b6bc10d0eb1bb175385d034f.tar.bz2
nixlib-eddf30cc93e1b778b6bc10d0eb1bb175385d034f.tar.lz
nixlib-eddf30cc93e1b778b6bc10d0eb1bb175385d034f.tar.xz
nixlib-eddf30cc93e1b778b6bc10d0eb1bb175385d034f.tar.zst
nixlib-eddf30cc93e1b778b6bc10d0eb1bb175385d034f.zip
nixos: introduce boot.growPartition (#33521)
Move it from being a profile
Diffstat (limited to 'nixos/modules/system/boot/grow-partition.nix')
-rw-r--r--nixos/modules/system/boot/grow-partition.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/nixos/modules/system/boot/grow-partition.nix b/nixos/modules/system/boot/grow-partition.nix
new file mode 100644
index 000000000000..c4c6d82dc5c8
--- /dev/null
+++ b/nixos/modules/system/boot/grow-partition.nix
@@ -0,0 +1,43 @@
+# This module automatically grows the root partition.
+# This allows an instance to be created with a bigger root filesystem
+# than provided by the machine image.
+
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+
+  options = {
+    boot.growPartition = mkEnableOption "grow the root partition on boot";
+  };
+
+  config = mkIf config.boot.growPartition {
+
+    boot.initrd.extraUtilsCommands = ''
+      copy_bin_and_libs ${pkgs.gawk}/bin/gawk
+      copy_bin_and_libs ${pkgs.gnused}/bin/sed
+      copy_bin_and_libs ${pkgs.utillinux}/sbin/sfdisk
+      copy_bin_and_libs ${pkgs.utillinux}/sbin/lsblk
+
+      substitute "${pkgs.cloud-utils}/bin/.growpart-wrapped" "$out/bin/growpart" \
+        --replace "${pkgs.bash}/bin/sh" "/bin/sh" \
+        --replace "awk" "gawk" \
+        --replace "sed" "gnused"
+
+      ln -s sed $out/bin/gnused
+    '';
+
+    boot.initrd.postDeviceCommands = ''
+      rootDevice="${config.fileSystems."/".device}"
+      if [ -e "$rootDevice" ]; then
+        rootDevice="$(readlink -f "$rootDevice")"
+        parentDevice="$(lsblk -npo PKNAME "$rootDevice")"
+        TMPDIR=/run sh $(type -P growpart) "$parentDevice" "''${rootDevice#$parentDevice}"
+        udevadm settle
+      fi
+    '';
+
+  };
+
+}