summary refs log tree commit diff
path: root/nixos/modules/system/boot/emergency-mode.nix
diff options
context:
space:
mode:
authorEmery Hemingway <emery@vfemail.net>2014-07-25 14:05:57 -0400
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-07-30 16:19:26 +0200
commit63d259df32ab969c46aa839a77e8d86cb8f734cf (patch)
tree37823fa540fdc124d84806bcf2f57f8d236efdef /nixos/modules/system/boot/emergency-mode.nix
parent1cc6dc198466eb451beb2daa6314a345f1853dab (diff)
downloadnixlib-63d259df32ab969c46aa839a77e8d86cb8f734cf.tar
nixlib-63d259df32ab969c46aa839a77e8d86cb8f734cf.tar.gz
nixlib-63d259df32ab969c46aa839a77e8d86cb8f734cf.tar.bz2
nixlib-63d259df32ab969c46aa839a77e8d86cb8f734cf.tar.lz
nixlib-63d259df32ab969c46aa839a77e8d86cb8f734cf.tar.xz
nixlib-63d259df32ab969c46aa839a77e8d86cb8f734cf.tar.zst
nixlib-63d259df32ab969c46aa839a77e8d86cb8f734cf.zip
nixos: tmp on tmpfs option
/tmp cleaning is done by systemd rather than stage-2-init
enableEmergencyMode moved from systemd to seperate module
new option to mount tmp on tmpfs
new option to enable additional units shipped with systemd
Diffstat (limited to 'nixos/modules/system/boot/emergency-mode.nix')
-rw-r--r--nixos/modules/system/boot/emergency-mode.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/nixos/modules/system/boot/emergency-mode.nix b/nixos/modules/system/boot/emergency-mode.nix
new file mode 100644
index 000000000000..9cdab8416192
--- /dev/null
+++ b/nixos/modules/system/boot/emergency-mode.nix
@@ -0,0 +1,37 @@
+{ config, lib, ... }:
+
+with lib;
+
+{
+
+  ###### interface
+
+  options = {
+
+    systemd.enableEmergencyMode = mkOption {
+      default = true;
+      type = types.bool;
+      description = ''
+        Whether to enable emergency mode, which is an
+        <command>sulogin</command> shell started on the console if
+        mounting a filesystem fails.  Since some machines (like EC2
+        instances) have no console of any kind, emergency mode doesn't
+        make sense, and it's better to continue with the boot insofar
+        as possible.
+      '';
+    };
+
+  };
+
+  ###### implementation
+
+  config = {
+
+    systemd.additionalUpstreamSystemUnits = optionals
+      config.systemd.enableEmergencyMode [
+        "emergency.target" "emergency.service"
+      ];
+
+  };
+
+}
\ No newline at end of file