summary refs log tree commit diff
path: root/nixos/modules/system/activation/top-level.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-31 13:26:06 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-31 13:26:06 +0100
commitc1159edc65989d6b33aa68e0822ec6e388576b8e (patch)
tree6f15c91b1f24c7a360d1fbd76548bbe1a655d105 /nixos/modules/system/activation/top-level.nix
parent456d8ec52b640ff67c88d04c89ea59836953b38f (diff)
downloadnixlib-c1159edc65989d6b33aa68e0822ec6e388576b8e.tar
nixlib-c1159edc65989d6b33aa68e0822ec6e388576b8e.tar.gz
nixlib-c1159edc65989d6b33aa68e0822ec6e388576b8e.tar.bz2
nixlib-c1159edc65989d6b33aa68e0822ec6e388576b8e.tar.lz
nixlib-c1159edc65989d6b33aa68e0822ec6e388576b8e.tar.xz
nixlib-c1159edc65989d6b33aa68e0822ec6e388576b8e.tar.zst
nixlib-c1159edc65989d6b33aa68e0822ec6e388576b8e.zip
Remove remaining references to Upstart
Diffstat (limited to 'nixos/modules/system/activation/top-level.nix')
-rw-r--r--nixos/modules/system/activation/top-level.nix15
1 files changed, 3 insertions, 12 deletions
diff --git a/nixos/modules/system/activation/top-level.nix b/nixos/modules/system/activation/top-level.nix
index 6fd8bf241f50..ada961316755 100644
--- a/nixos/modules/system/activation/top-level.nix
+++ b/nixos/modules/system/activation/top-level.nix
@@ -80,9 +80,9 @@ let
 
   # Putting it all together.  This builds a store path containing
   # symlinks to the various parts of the built configuration (the
-  # kernel, the Upstart services, the init scripts, etc.) as well as a
-  # script `switch-to-configuration' that activates the configuration
-  # and makes it bootable.
+  # kernel, systemd units, init scripts, etc.) as well as a script
+  # `switch-to-configuration' that activates the configuration and
+  # makes it bootable.
   system = pkgs.stdenv.mkDerivation {
     name = "nixos-${config.system.nixosVersion}";
     preferLocalBuild = true;
@@ -99,15 +99,6 @@ let
     activationScript = config.system.activationScripts.script;
     nixosVersion = config.system.nixosVersion;
 
-    jobs = map (j: j.name) (attrValues config.jobs);
-
-    # Pass the names of all Upstart tasks to the activation script.
-    tasks = attrValues (mapAttrs (n: v: if v.task then ["[${v.name}]=1"] else []) config.jobs);
-
-    # Pass the names of all Upstart jobs that shouldn't be restarted
-    # to the activation script.
-    noRestartIfChanged = attrValues (mapAttrs (n: v: if v.restartIfChanged then [] else ["[${v.name}]=1"]) config.jobs);
-
     configurationName = config.boot.loader.grub.configurationName;
 
     # Needed by switch-to-configuration.