summary refs log tree commit diff
path: root/nixos/modules/system/activation/top-level.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-12-15 12:08:31 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-12-15 16:19:35 +0100
commit88412c865d930a22c193bb83255336f62e65a9a1 (patch)
treed45135b92bf9c9dd266754cbe909b47498579df5 /nixos/modules/system/activation/top-level.nix
parent32e41c22803fe00379d80b01e7914f9c0a506b22 (diff)
downloadnixlib-88412c865d930a22c193bb83255336f62e65a9a1.tar
nixlib-88412c865d930a22c193bb83255336f62e65a9a1.tar.gz
nixlib-88412c865d930a22c193bb83255336f62e65a9a1.tar.bz2
nixlib-88412c865d930a22c193bb83255336f62e65a9a1.tar.lz
nixlib-88412c865d930a22c193bb83255336f62e65a9a1.tar.xz
nixlib-88412c865d930a22c193bb83255336f62e65a9a1.tar.zst
nixlib-88412c865d930a22c193bb83255336f62e65a9a1.zip
Fix ANSI escape in warning messages
Seems to have been broken by accident in 7d1ddae58e465a1708967c9fee651c33819969c6.
Diffstat (limited to 'nixos/modules/system/activation/top-level.nix')
-rw-r--r--nixos/modules/system/activation/top-level.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/system/activation/top-level.nix b/nixos/modules/system/activation/top-level.nix
index b8ea7fd7b9ad..d7a1e205b4d4 100644
--- a/nixos/modules/system/activation/top-level.nix
+++ b/nixos/modules/system/activation/top-level.nix
@@ -88,7 +88,7 @@ let
 
   failed = map (x: x.message) (filter (x: !x.assertion) config.assertions);
 
-  showWarnings = res: fold (w: x: builtins.trace "^[[1;31mwarning: ${w}^[[0m" x) res config.warnings;
+  showWarnings = res: fold (w: x: builtins.trace "warning: ${w}" x) res config.warnings;
 
   # Putting it all together.  This builds a store path containing
   # symlinks to the various parts of the built configuration (the