summary refs log tree commit diff
path: root/nixos/modules/system/activation/top-level.nix
diff options
context:
space:
mode:
authoredef <edef@edef.eu>2017-08-12 21:14:36 +0200
committeredef <edef@edef.eu>2018-03-05 12:05:01 -0500
commit2fa1165e89db2c49ccd616a39507c9bdd30c50d2 (patch)
tree6905651ed0fa2cb6a797cf37f53349bec31a74a8 /nixos/modules/system/activation/top-level.nix
parente65676d25dd1789b714596e1204891749b45ad1f (diff)
downloadnixlib-2fa1165e89db2c49ccd616a39507c9bdd30c50d2.tar
nixlib-2fa1165e89db2c49ccd616a39507c9bdd30c50d2.tar.gz
nixlib-2fa1165e89db2c49ccd616a39507c9bdd30c50d2.tar.bz2
nixlib-2fa1165e89db2c49ccd616a39507c9bdd30c50d2.tar.lz
nixlib-2fa1165e89db2c49ccd616a39507c9bdd30c50d2.tar.xz
nixlib-2fa1165e89db2c49ccd616a39507c9bdd30c50d2.tar.zst
nixlib-2fa1165e89db2c49ccd616a39507c9bdd30c50d2.zip
switch-to-configuration: use Net::DBus to retrieve the list of units
This resolves the FIXME, and opens up the possibility of using more of
the systemd DBus interface to make things more robust.
Diffstat (limited to 'nixos/modules/system/activation/top-level.nix')
-rw-r--r--nixos/modules/system/activation/top-level.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/modules/system/activation/top-level.nix b/nixos/modules/system/activation/top-level.nix
index 091a2e412eed..f4af9a580fde 100644
--- a/nixos/modules/system/activation/top-level.nix
+++ b/nixos/modules/system/activation/top-level.nix
@@ -127,7 +127,8 @@ let
       configurationName = config.boot.loader.grub.configurationName;
 
       # Needed by switch-to-configuration.
-      perl = "${pkgs.perl}/bin/perl -I${pkgs.perlPackages.FileSlurp}/lib/perl5/site_perl";
+
+      perl = "${pkgs.perl}/bin/perl " + (concatMapStringsSep " " (lib: "-I${lib}/${pkgs.perl.libPrefix}") (with perlPackages; [ FileSlurp NetDBus XMLParser XMLTwig ]));
   } else throw "\nFailed assertions:\n${concatStringsSep "\n" (map (x: "- ${x}") failed)}");
 
   # Replace runtime dependencies