summary refs log tree commit diff
path: root/nixos/modules/system/activation/top-level.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2016-09-27 15:28:11 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2016-09-29 13:06:41 +0200
commit0cb16a6955ff6ef447a81caab02a8389b2d19dd4 (patch)
tree79ba36035f4996690f7f073bd99ad49cfa110abd /nixos/modules/system/activation/top-level.nix
parent518340624d92c7d802b23e73b078010a505b3609 (diff)
downloadnixlib-0cb16a6955ff6ef447a81caab02a8389b2d19dd4.tar
nixlib-0cb16a6955ff6ef447a81caab02a8389b2d19dd4.tar.gz
nixlib-0cb16a6955ff6ef447a81caab02a8389b2d19dd4.tar.bz2
nixlib-0cb16a6955ff6ef447a81caab02a8389b2d19dd4.tar.lz
nixlib-0cb16a6955ff6ef447a81caab02a8389b2d19dd4.tar.xz
nixlib-0cb16a6955ff6ef447a81caab02a8389b2d19dd4.tar.zst
nixlib-0cb16a6955ff6ef447a81caab02a8389b2d19dd4.zip
Add stdenvNoCC
This is a standard environment that doesn't contain a C/C++
compiler. This is mostly to prevent trivial builders like runCommand
and substituteAll from pulling in gcc for simple configuration changes
on NixOS.
Diffstat (limited to 'nixos/modules/system/activation/top-level.nix')
-rw-r--r--nixos/modules/system/activation/top-level.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/system/activation/top-level.nix b/nixos/modules/system/activation/top-level.nix
index 2d1b0ffb54ce..0c08375da646 100644
--- a/nixos/modules/system/activation/top-level.nix
+++ b/nixos/modules/system/activation/top-level.nix
@@ -98,7 +98,7 @@ let
   # `switch-to-configuration' that activates the configuration and
   # makes it bootable.
   baseSystem = showWarnings (
-    if [] == failed then pkgs.stdenv.mkDerivation {
+    if [] == failed then pkgs.stdenvNoCC.mkDerivation {
       name = let hn = config.networking.hostName;
                  nn = if (hn != "") then hn else "unnamed";
           in "nixos-system-${nn}-${config.system.nixosLabel}";