summary refs log tree commit diff
path: root/nixos/modules/services/x11/xserver.nix
diff options
context:
space:
mode:
authorLuca Bruno <lucabru@src.gnome.org>2015-06-22 16:08:29 +0000
committerLuca Bruno <lucabru@src.gnome.org>2015-06-22 16:12:20 +0000
commitf00440fac5552b92098c020946a2ac45a2fe613b (patch)
tree843432d68a202decc5aff05b7d135b15899f9232 /nixos/modules/services/x11/xserver.nix
parent7907a8bcba6fe50e1f7fa8f8ee6a98df884031ad (diff)
downloadnixlib-f00440fac5552b92098c020946a2ac45a2fe613b.tar
nixlib-f00440fac5552b92098c020946a2ac45a2fe613b.tar.gz
nixlib-f00440fac5552b92098c020946a2ac45a2fe613b.tar.bz2
nixlib-f00440fac5552b92098c020946a2ac45a2fe613b.tar.lz
nixlib-f00440fac5552b92098c020946a2ac45a2fe613b.tar.xz
nixlib-f00440fac5552b92098c020946a2ac45a2fe613b.tar.zst
nixlib-f00440fac5552b92098c020946a2ac45a2fe613b.zip
nixos/x11: start session with dbus-launch
This is needed by most window managers. Desktop environments
usually launch dbus-launch if a session hasn't been started yet
so this shouldn't hurt. The worst it can happen is that one
dbus session will be unused in case it's started twice.

The GDM change is backported from recent gdm.
Diffstat (limited to 'nixos/modules/services/x11/xserver.nix')
-rw-r--r--nixos/modules/services/x11/xserver.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/nixos/modules/services/x11/xserver.nix b/nixos/modules/services/x11/xserver.nix
index 9fddc6a72104..1ec098fded6e 100644
--- a/nixos/modules/services/x11/xserver.nix
+++ b/nixos/modules/services/x11/xserver.nix
@@ -238,6 +238,14 @@ in
         '';
       };
 
+      startDbusSession = mkOption {
+        type = types.bool;
+        default = true;
+        description = ''
+          Whether to start a new DBus session when you log in with dbus-launch.
+        '';
+      };
+
       layout = mkOption {
         type = types.str;
         default = "us";