summary refs log tree commit diff
path: root/nixos/modules/services/x11/xserver.nix
diff options
context:
space:
mode:
authorHerwig Hochleitner <herwig@bendlas.net>2017-11-04 19:06:37 +0100
committerHerwig Hochleitner <herwig@bendlas.net>2017-11-05 01:51:13 +0100
commite64dc2543458b52abcd913bad87851f5d7db435d (patch)
tree24fa74a14db715c761ef06724edef5173bdaaa97 /nixos/modules/services/x11/xserver.nix
parent7be7698612e9fb04752f2e3c0ac9e2907ec21eb5 (diff)
downloadnixlib-e64dc2543458b52abcd913bad87851f5d7db435d.tar
nixlib-e64dc2543458b52abcd913bad87851f5d7db435d.tar.gz
nixlib-e64dc2543458b52abcd913bad87851f5d7db435d.tar.bz2
nixlib-e64dc2543458b52abcd913bad87851f5d7db435d.tar.lz
nixlib-e64dc2543458b52abcd913bad87851f5d7db435d.tar.xz
nixlib-e64dc2543458b52abcd913bad87851f5d7db435d.tar.zst
nixlib-e64dc2543458b52abcd913bad87851f5d7db435d.zip
Revert "services.xserver: assert that either desktop- or window manager is not "none""
This reverts commit 93c54acf97077567e8d6135a36f191e872b26692.
This reopens #30517 @nbp @Ma27

Breaking people's config for this is hardly reasonable as is. If it
absolutely cannot be avoided, at the very least, we need to provide
clear instructions on what people need to upgrade in their config. I
actually had to bisect to the commit, to even find out what property I
should change or define, as the error message was useless. It didn't
even mention a property name.

Discussion on the PR seems to be ongoing, so I'm reverting this, so we
don't break people's systems on unstable.
Diffstat (limited to 'nixos/modules/services/x11/xserver.nix')
-rw-r--r--nixos/modules/services/x11/xserver.nix12
1 files changed, 0 insertions, 12 deletions
diff --git a/nixos/modules/services/x11/xserver.nix b/nixos/modules/services/x11/xserver.nix
index 58dc75bcb4e6..d4fe475690ce 100644
--- a/nixos/modules/services/x11/xserver.nix
+++ b/nixos/modules/services/x11/xserver.nix
@@ -161,15 +161,6 @@ in
         '';
       };
 
-      plainX = mkOption {
-        type = types.bool;
-        default = false;
-        description = ''
-          Whether the X11 session can be plain (without DM/WM) and
-          the Xsession script will be used as fallback or not.
-        '';
-      };
-
       autorun = mkOption {
         type = types.bool;
         default = true;
@@ -561,9 +552,6 @@ in
                 + "${toString (length primaryHeads)} heads set to primary: "
                 + concatMapStringsSep ", " (x: x.output) primaryHeads;
       })
-      { assertion = cfg.desktopManager.default == "none" && cfg.windowManager.default == "none" -> cfg.plainX;
-        message = "Either the desktop manager or the window manager shouldn't be `none`! To explicitly allow this, you can also set `services.xserver.plainX` to `true`.";
-      }
     ];
 
     environment.etc =