summary refs log tree commit diff
path: root/nixos/modules/services/x11/xserver.nix
diff options
context:
space:
mode:
authorzimbatm <zimbatm@zimbatm.com>2016-10-10 21:35:37 +0100
committerGitHub <noreply@github.com>2016-10-10 21:35:37 +0100
commite026d5b9c813084d029382f3af72a57e3142fae1 (patch)
tree5332fd73a4a549b348ba8982ff448dc566edc1b8 /nixos/modules/services/x11/xserver.nix
parentcb9d26d5cb1a4b900de98cfd895770dd4c1b13b2 (diff)
downloadnixlib-e026d5b9c813084d029382f3af72a57e3142fae1.tar
nixlib-e026d5b9c813084d029382f3af72a57e3142fae1.tar.gz
nixlib-e026d5b9c813084d029382f3af72a57e3142fae1.tar.bz2
nixlib-e026d5b9c813084d029382f3af72a57e3142fae1.tar.lz
nixlib-e026d5b9c813084d029382f3af72a57e3142fae1.tar.xz
nixlib-e026d5b9c813084d029382f3af72a57e3142fae1.tar.zst
nixlib-e026d5b9c813084d029382f3af72a57e3142fae1.zip
x11 module: don't restart the display manager indefinitely (#19418)
* x11 module: don't restart the display manager indefinitely

If the display managers crashes continuously in loops it prevents the
user from switching to the console and try to fix things. Especially
when using the "auto" display manager it can happen quite easily.

* x11 module: fix display manager restart timeouts

It takes more than 1 second to boot the X server.
Diffstat (limited to 'nixos/modules/services/x11/xserver.nix')
-rw-r--r--nixos/modules/services/x11/xserver.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/nixos/modules/services/x11/xserver.nix b/nixos/modules/services/x11/xserver.nix
index ec2f3a4f8bb1..e34f0c216639 100644
--- a/nixos/modules/services/x11/xserver.nix
+++ b/nixos/modules/services/x11/xserver.nix
@@ -539,6 +539,10 @@ in
           Restart = "always";
           RestartSec = "200ms";
           SyslogIdentifier = "display-manager";
+          # Stop restarting if the display manager stops (crashes) 2 times
+          # in one minute. Starting X typically takes 3-4s.
+          StartLimitInterval = "30s";
+          StartLimitBurst = "3";
         };
       };