summary refs log tree commit diff
path: root/nixos/modules/services/x11/xserver.nix
diff options
context:
space:
mode:
authorAlexander Ried <ried@mytum.de>2016-10-03 17:04:29 +0200
committerAlexander Ried <ried@mytum.de>2016-10-15 20:32:14 +0200
commitc2922a9157a8d8db62cee763e254113c3766461e (patch)
treec0fbdd259fb2ed23f154f8993b45d982092d83e6 /nixos/modules/services/x11/xserver.nix
parent8ec776eb73ae772da60bd01b172789835dfb3cd5 (diff)
downloadnixlib-c2922a9157a8d8db62cee763e254113c3766461e.tar
nixlib-c2922a9157a8d8db62cee763e254113c3766461e.tar.gz
nixlib-c2922a9157a8d8db62cee763e254113c3766461e.tar.bz2
nixlib-c2922a9157a8d8db62cee763e254113c3766461e.tar.lz
nixlib-c2922a9157a8d8db62cee763e254113c3766461e.tar.xz
nixlib-c2922a9157a8d8db62cee763e254113c3766461e.tar.zst
nixlib-c2922a9157a8d8db62cee763e254113c3766461e.zip
xserverArgs fuckup
gnome-x-session provides good defaults which we really should not
override.
We have to add assertions to gdm.nix if the user specified one of those.

enableTCP must be configured through a gnome setting

dunno why we have terminate but it probably breaks stuff

We should expose configFile so we can use it from gdm module.
Diffstat (limited to 'nixos/modules/services/x11/xserver.nix')
-rw-r--r--nixos/modules/services/x11/xserver.nix15
1 files changed, 8 insertions, 7 deletions
diff --git a/nixos/modules/services/x11/xserver.nix b/nixos/modules/services/x11/xserver.nix
index e34f0c216639..298f30858cef 100644
--- a/nixos/modules/services/x11/xserver.nix
+++ b/nixos/modules/services/x11/xserver.nix
@@ -546,18 +546,19 @@ in
         };
       };
 
-    services.xserver.displayManager.xserverArgs =
-      [ "-terminate"
+    services.xserver.displayManager.xserverArgs = mkDefault (
+      [ #"-terminate"
         "-config ${configFile}"
         "-xkbdir" "${cfg.xkbDir}"
         # Log at the default verbosity level to stderr rather than /var/log/X.*.log.
-        "-verbose" "3" "-logfile" "/dev/null"
-      ] ++ optional (cfg.display != null) ":${toString cfg.display}"
-        ++ optional (cfg.tty     != null) "vt${toString cfg.tty}"
+        #"-verbose" "3" "-logfile" "/dev/null"
+      ] #++ optional (cfg.display != null) ":${toString cfg.display}"
+        #++ optional (cfg.tty     != null) "vt${toString cfg.tty}"
         ++ optional (cfg.dpi     != null) "-dpi ${toString cfg.dpi}"
-        ++ optional (!cfg.enableTCP) "-nolisten tcp"
+        #++ optional (!cfg.enableTCP) "-nolisten tcp");
         ++ optional (cfg.autoRepeatDelay != null) "-ardelay ${toString cfg.autoRepeatDelay}"
-        ++ optional (cfg.autoRepeatInterval != null) "-arinterval ${toString cfg.autoRepeatInterval}";
+        ++ optional (cfg.autoRepeatInterval != null) "-arinterval ${toString cfg.autoRepeatInterval}"
+);
 
     services.xserver.modules =
       concatLists (catAttrs "modules" cfg.drivers) ++