summary refs log tree commit diff
path: root/nixos/modules/services/x11/xserver.nix
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2016-03-18 10:31:40 +0100
committerPeter Simons <simons@cryp.to>2016-03-18 11:06:31 +0100
commit5391882ebd781149e213e8817fba6ac3c503740c (patch)
treeaa861d183a61b1fd68dc164b9520d020b25ad093 /nixos/modules/services/x11/xserver.nix
parent9c10ac957dd77e22e9c4f29cd54652d9547c624a (diff)
downloadnixlib-5391882ebd781149e213e8817fba6ac3c503740c.tar
nixlib-5391882ebd781149e213e8817fba6ac3c503740c.tar.gz
nixlib-5391882ebd781149e213e8817fba6ac3c503740c.tar.bz2
nixlib-5391882ebd781149e213e8817fba6ac3c503740c.tar.lz
nixlib-5391882ebd781149e213e8817fba6ac3c503740c.tar.xz
nixlib-5391882ebd781149e213e8817fba6ac3c503740c.tar.zst
nixlib-5391882ebd781149e213e8817fba6ac3c503740c.zip
services.xserver.startGnuPGAgent: remove obsolete NixOS option
GnuPG 2.1.x changed the way the gpg-agent works, and that new approach no
longer requires (or even supports) the "start everything as a child of the
agent" scheme we've implemented in NixOS for older versions.

To configure the gpg-agent for your X session, add the following code to
~/.xsession or some other appropriate place that's sourced at start-up:

    gpg-connect-agent /bye
    GPG_TTY=$(tty)
    export GPG_TTY

If you want to use gpg-agent for SSH, too, also add the settings

    unset SSH_AGENT_PID
    export SSH_AUTH_SOCK="${HOME}/.gnupg/S.gpg-agent.ssh"

and make sure that

    enable-ssh-support

is included in your ~/.gnupg/gpg-agent.conf.

The gpg-agent(1) man page has more details about this subject, i.e. in the
"EXAMPLES" section.
Diffstat (limited to 'nixos/modules/services/x11/xserver.nix')
-rw-r--r--nixos/modules/services/x11/xserver.nix20
1 files changed, 1 insertions, 19 deletions
diff --git a/nixos/modules/services/x11/xserver.nix b/nixos/modules/services/x11/xserver.nix
index abbe00cc8881..0fcea6ce5e4f 100644
--- a/nixos/modules/services/x11/xserver.nix
+++ b/nixos/modules/services/x11/xserver.nix
@@ -219,17 +219,6 @@ in
         '';
       };
 
-      startGnuPGAgent = mkOption {
-        type = types.bool;
-        default = false;
-        description = ''
-          Whether to start the GnuPG agent when you log in.  The GnuPG agent
-          remembers private keys for you so that you don't have to type in
-          passphrases every time you make an SSH connection or sign/encrypt
-          data.  Use <command>ssh-add</command> to add a key to the agent.
-        '';
-      };
-
       startDbusSession = mkOption {
         type = types.bool;
         default = true;
@@ -444,14 +433,7 @@ in
       in optional (driver != null) ({ inherit name; driverName = name; } // driver));
 
     assertions =
-      [ { assertion = !(config.programs.ssh.startAgent && cfg.startGnuPGAgent);
-          message =
-            ''
-              The OpenSSH agent and GnuPG agent cannot be started both. Please
-              choose between ‘programs.ssh.startAgent’ and ‘services.xserver.startGnuPGAgent’.
-            '';
-        }
-        { assertion = config.security.polkit.enable;
+      [ { assertion = config.security.polkit.enable;
           message = "X11 requires Polkit to be enabled (‘security.polkit.enable = true’).";
         }
       ];