summary refs log tree commit diff
path: root/nixos/modules/services/x11/xserver.nix
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2018-03-18 05:28:14 +0300
committerNikolay Amiantov <ab@fmap.me>2018-03-26 14:01:49 +0300
commit4f0b59de9abde4d8b8c30dd364b08bb111391d3e (patch)
tree8240e9dcb6c44df14c686f1d73f2fe4c192397a4 /nixos/modules/services/x11/xserver.nix
parenta798ec30f9bf2741a914c4757260dd855029f63d (diff)
downloadnixlib-4f0b59de9abde4d8b8c30dd364b08bb111391d3e.tar
nixlib-4f0b59de9abde4d8b8c30dd364b08bb111391d3e.tar.gz
nixlib-4f0b59de9abde4d8b8c30dd364b08bb111391d3e.tar.bz2
nixlib-4f0b59de9abde4d8b8c30dd364b08bb111391d3e.tar.lz
nixlib-4f0b59de9abde4d8b8c30dd364b08bb111391d3e.tar.xz
nixlib-4f0b59de9abde4d8b8c30dd364b08bb111391d3e.tar.zst
nixlib-4f0b59de9abde4d8b8c30dd364b08bb111391d3e.zip
xserver service: cleanup LD_LIBRARY_PATH
X libraries in LD_LIBRARY_PATH seem to not be needed anymore.
I've tracked this addition as far as I could
(02cef04c8187f12fd160d5fedf0ec8a928f02639) and they seem to be added for unfree
NVIDIA and ATI drivers but at least for NVIDIA they are not needed anymore. We
can add them with patchelf instead if it turns out to be the case with ATI.
Diffstat (limited to 'nixos/modules/services/x11/xserver.nix')
-rw-r--r--nixos/modules/services/x11/xserver.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/nixos/modules/services/x11/xserver.nix b/nixos/modules/services/x11/xserver.nix
index f96d3c5afbac..a89d446187e0 100644
--- a/nixos/modules/services/x11/xserver.nix
+++ b/nixos/modules/services/x11/xserver.nix
@@ -640,9 +640,7 @@ in
 
         environment =
           {
-            XORG_DRI_DRIVER_PATH = "/run/opengl-driver/lib/dri"; # !!! Depends on the driver selected at runtime.
-            LD_LIBRARY_PATH = concatStringsSep ":" (
-              [ "${xorg.libX11.out}/lib" "${xorg.libXext.out}/lib" "/run/opengl-driver/lib" ]
+            LD_LIBRARY_PATH = concatStringsSep ":" ([ "/run/opengl-driver/lib" ]
               ++ concatLists (catAttrs "libPath" cfg.drivers));
           } // cfg.displayManager.job.environment;