summary refs log tree commit diff
path: root/nixos/modules/services/x11/xserver.nix
diff options
context:
space:
mode:
authorDomen Kožar <domen@dev.si>2016-02-27 10:08:37 +0000
committerDomen Kožar <domen@dev.si>2016-02-27 10:08:37 +0000
commit04422bb3ca8f1c09ac45817f6926199f9bfbf84f (patch)
tree6fc31a73fb4595e5f348657cf2f36de90ce606ae /nixos/modules/services/x11/xserver.nix
parent13afef0d8ec6058e8d42f3ea8cb1f0932bef0c2f (diff)
parent392ca77d4c0c5e05ad23378de370ea964c29848f (diff)
downloadnixlib-04422bb3ca8f1c09ac45817f6926199f9bfbf84f.tar
nixlib-04422bb3ca8f1c09ac45817f6926199f9bfbf84f.tar.gz
nixlib-04422bb3ca8f1c09ac45817f6926199f9bfbf84f.tar.bz2
nixlib-04422bb3ca8f1c09ac45817f6926199f9bfbf84f.tar.lz
nixlib-04422bb3ca8f1c09ac45817f6926199f9bfbf84f.tar.xz
nixlib-04422bb3ca8f1c09ac45817f6926199f9bfbf84f.tar.zst
nixlib-04422bb3ca8f1c09ac45817f6926199f9bfbf84f.zip
Merge pull request #8630 from lihop/nixos/fix-formatting
nixos: fix formatting of option examples
Diffstat (limited to 'nixos/modules/services/x11/xserver.nix')
-rw-r--r--nixos/modules/services/x11/xserver.nix17
1 files changed, 10 insertions, 7 deletions
diff --git a/nixos/modules/services/x11/xserver.nix b/nixos/modules/services/x11/xserver.nix
index 653c97d7e6fa..cfe5e7f960c7 100644
--- a/nixos/modules/services/x11/xserver.nix
+++ b/nixos/modules/services/x11/xserver.nix
@@ -156,13 +156,16 @@ in
       inputClassSections = mkOption {
         type = types.listOf types.lines;
         default = [];
-        example = [ ''
-           Identifier      "Trackpoint Wheel Emulation"
-           MatchProduct    "ThinkPad USB Keyboard with TrackPoint"
-           Option          "EmulateWheel"          "true
-           Option          "EmulateWheelButton"    "2"
-           Option          "Emulate3Buttons"       "false"
-          '' ];
+        example = literalExample ''
+          [ '''
+              Identifier      "Trackpoint Wheel Emulation"
+              MatchProduct    "ThinkPad USB Keyboard with TrackPoint"
+              Option          "EmulateWheel"          "true
+              Option          "EmulateWheelButton"    "2"
+              Option          "Emulate3Buttons"       "false"
+            '''
+          ]
+        '';
         description = "Content of additional InputClass sections of the X server configuration file.";
       };