summary refs log tree commit diff
path: root/nixos/modules/services/x11/unclutter.nix
diff options
context:
space:
mode:
authorAnders Papitto <anderspapitto@gmail.com>2016-07-05 19:18:21 -0700
committerAnders Papitto <anderspapitto@gmail.com>2016-07-05 19:18:21 -0700
commit49879fa96b91d64e3c1a77ffe9665c65df24e332 (patch)
treefde56a833da6420794ab03816b777adefa444b89 /nixos/modules/services/x11/unclutter.nix
parent54fa0cfe4eef7e54e23380704af70ee7b65473ce (diff)
downloadnixlib-49879fa96b91d64e3c1a77ffe9665c65df24e332.tar
nixlib-49879fa96b91d64e3c1a77ffe9665c65df24e332.tar.gz
nixlib-49879fa96b91d64e3c1a77ffe9665c65df24e332.tar.bz2
nixlib-49879fa96b91d64e3c1a77ffe9665c65df24e332.tar.lz
nixlib-49879fa96b91d64e3c1a77ffe9665c65df24e332.tar.xz
nixlib-49879fa96b91d64e3c1a77ffe9665c65df24e332.tar.zst
nixlib-49879fa96b91d64e3c1a77ffe9665c65df24e332.zip
unclutter: respect xserver.display variable
Diffstat (limited to 'nixos/modules/services/x11/unclutter.nix')
-rw-r--r--nixos/modules/services/x11/unclutter.nix8
1 files changed, 1 insertions, 7 deletions
diff --git a/nixos/modules/services/x11/unclutter.nix b/nixos/modules/services/x11/unclutter.nix
index 3260fdb3d54d..ebc195d108d0 100644
--- a/nixos/modules/services/x11/unclutter.nix
+++ b/nixos/modules/services/x11/unclutter.nix
@@ -39,12 +39,6 @@ in {
       default = 1;
     };
 
-    displayName = mkOption {
-      description = "Name of the X11 display";
-      type = types.str;
-      default = ":0";
-    };
-
     excluded = mkOption {
       description = "Names of windows where unclutter should not apply";
       type = types.listOf types.str;
@@ -67,7 +61,7 @@ in {
       serviceConfig.ExecStart = ''
         ${cfg.package}/bin/unclutter \
           -idle ${toString cfg.timeout} \
-          -display ${cfg.displayName} \
+          -display :${toString config.services.xserver.display} \
           -jitter ${toString (cfg.threeshold - 1)} \
           ${optionalString cfg.keystroke "-keystroke"} \
           ${concatMapStrings (x: " -"+x) cfg.extraOptions} \