summary refs log tree commit diff
path: root/nixos/modules/services/x11/hardware/libinput.nix
diff options
context:
space:
mode:
authorBenjamin Staffin <benley@gmail.com>2017-10-09 12:07:19 -0700
committerGitHub <noreply@github.com>2017-10-09 12:07:19 -0700
commitb3df084c706c4206c07d151cb4375f594fe6a7ac (patch)
tree0ef33ae1338b39982e74f3e9223fbf5c00b2c91c /nixos/modules/services/x11/hardware/libinput.nix
parentf2ce15be9d4a943e745856cc197b906466b36f6e (diff)
downloadnixlib-b3df084c706c4206c07d151cb4375f594fe6a7ac.tar
nixlib-b3df084c706c4206c07d151cb4375f594fe6a7ac.tar.gz
nixlib-b3df084c706c4206c07d151cb4375f594fe6a7ac.tar.bz2
nixlib-b3df084c706c4206c07d151cb4375f594fe6a7ac.tar.lz
nixlib-b3df084c706c4206c07d151cb4375f594fe6a7ac.tar.xz
nixlib-b3df084c706c4206c07d151cb4375f594fe6a7ac.tar.zst
nixlib-b3df084c706c4206c07d151cb4375f594fe6a7ac.zip
nixos: minor X11 option description improvements (#30035)
Diffstat (limited to 'nixos/modules/services/x11/hardware/libinput.nix')
-rw-r--r--nixos/modules/services/x11/hardware/libinput.nix15
1 files changed, 9 insertions, 6 deletions
diff --git a/nixos/modules/services/x11/hardware/libinput.nix b/nixos/modules/services/x11/hardware/libinput.nix
index d75c785270b3..44555cb6e2a9 100644
--- a/nixos/modules/services/x11/hardware/libinput.nix
+++ b/nixos/modules/services/x11/hardware/libinput.nix
@@ -75,12 +75,13 @@ in {
         default = null;
         description =
           ''
-            Enables a click method. Permitted values are none, buttonareas, clickfinger.
+            Enables a click method. Permitted values are <literal>none</literal>,
+            <literal>buttonareas</literal>, <literal>clickfinger</literal>.
             Not all devices support all methods, if an option is unsupported,
-            the default click method for this device is used. 
+            the default click method for this device is used.
           '';
       };
-      
+
       leftHanded = mkOption {
         type = types.bool;
         default = false;
@@ -96,7 +97,7 @@ in {
             simultaneously produces a middle mouse button click.
           '';
       };
-      
+
       naturalScrolling = mkOption {
         type = types.bool;
         default = false;
@@ -120,7 +121,8 @@ in {
         example = "edge";
         description =
           ''
-            Specify the scrolling method.
+            Specify the scrolling method: <literal>twofinger</literal>, <literal>edge</literal>,
+            or <literal>none</literal>
           '';
       };
 
@@ -141,7 +143,8 @@ in {
         example = "disabled";
         description =
           ''
-            Sets the send events mode to disabled, enabled, or "disable when an external mouse is connected".
+            Sets the send events mode to <literal>disabled</literal>, <literal>enabled</literal>,
+            or <literal>disabled-on-external-mouse</literal>
           '';
       };