summary refs log tree commit diff
path: root/nixos/modules/services/x11/hardware/libinput.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2016-08-08 13:36:30 +0200
committerProfpatsch <mail@profpatsch.de>2016-08-08 14:01:07 +0200
commit85ed3ca9c7bf12d0095aa36c79d7d98c751fe429 (patch)
tree4242596124f4164775d27a0998d9c6cd399fda4b /nixos/modules/services/x11/hardware/libinput.nix
parentf242b752fec061ec5afe6f1b3b5f948bded23e9a (diff)
downloadnixlib-85ed3ca9c7bf12d0095aa36c79d7d98c751fe429.tar
nixlib-85ed3ca9c7bf12d0095aa36c79d7d98c751fe429.tar.gz
nixlib-85ed3ca9c7bf12d0095aa36c79d7d98c751fe429.tar.bz2
nixlib-85ed3ca9c7bf12d0095aa36c79d7d98c751fe429.tar.lz
nixlib-85ed3ca9c7bf12d0095aa36c79d7d98c751fe429.tar.xz
nixlib-85ed3ca9c7bf12d0095aa36c79d7d98c751fe429.tar.zst
nixlib-85ed3ca9c7bf12d0095aa36c79d7d98c751fe429.zip
libinput.accelProfile: improve docs & new default
The link to some (of course non-existing, i.e. freedesktop) “libinput”
documentation is replaced by a piece of the API documentation.

The default is changed since the documentation suggests `adaptive`
should be it.
https://wayland.freedesktop.org/libinput/doc/latest/group__config.html#gad63796972347f318b180e322e35cee79

Also fix a missing string conversion for `scrollButton`.
Diffstat (limited to 'nixos/modules/services/x11/hardware/libinput.nix')
-rw-r--r--nixos/modules/services/x11/hardware/libinput.nix21
1 files changed, 13 insertions, 8 deletions
diff --git a/nixos/modules/services/x11/hardware/libinput.nix b/nixos/modules/services/x11/hardware/libinput.nix
index 47ce9e566045..b358550ba41d 100644
--- a/nixos/modules/services/x11/hardware/libinput.nix
+++ b/nixos/modules/services/x11/hardware/libinput.nix
@@ -25,16 +25,21 @@ in {
 
       accelProfile = mkOption {
         type = types.enum [ "flat" "adaptive" ];
-        default = "flat";
-        example = "adaptive";
+        default = "adaptive";
+        example = "flat";
         description =
           ''
-            Sets  the pointer acceleration profile to the given profile. Permitted values are adaptive, flat.
-            Not all devices support this option or all profiles. If a profile is unsupported, the default profile
-            for this is used. For a description on the profiles and their behavior, see the libinput documentation.
+            Sets  the pointer acceleration profile to the given profile.
+            Permitted values are adaptive, flat.
+            Not all devices support this option or all profiles.
+            If a profile is unsupported, the default profile for this is used.
+            <literal>flat</literal>: Pointer motion is accelerated by a constant
+            (device-specific) factor, depending on the current speed.
+            <literal>adaptive</literal>: Pointer acceleration depends on the input speed.
+            This is the default profile for most devices.
           '';
-      };    
-      
+      };
+
       accelSpeed = mkOption {
         type = types.nullOr types.string;
         default = null;
@@ -216,7 +221,7 @@ in {
           Option "LeftHanded" "${xorgBool cfg.leftHanded}"
           Option "MiddleEmulation" "${xorgBool cfg.middleEmulation}"
           Option "NaturalScrolling" "${xorgBool cfg.naturalScrolling}"
-          ${optionalString (cfg.scrollButton != null) ''Option "ScrollButton" "${cfg.scrollButton}"''}
+          ${optionalString (cfg.scrollButton != null) ''Option "ScrollButton" "${toString cfg.scrollButton}"''}
           Option "ScrollMethod" "${cfg.scrollMethod}"
           Option "HorizontalScrolling" "${xorgBool cfg.horizontalScrolling}"
           Option "SendEventsMode" "${cfg.sendEventsMode}"