summary refs log tree commit diff
path: root/nixos/modules/services/x11/display-managers/lightdm.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-15 14:47:51 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-15 14:47:51 +0200
commita2c820c6786ef8275213838ad0bdd77b970a4168 (patch)
treeca4a67b5220aa069aef67a7948f7e151933db9a9 /nixos/modules/services/x11/display-managers/lightdm.nix
parent3f2c0bf9bde96260276fe487e2f85b1858d61c47 (diff)
downloadnixlib-a2c820c6786ef8275213838ad0bdd77b970a4168.tar
nixlib-a2c820c6786ef8275213838ad0bdd77b970a4168.tar.gz
nixlib-a2c820c6786ef8275213838ad0bdd77b970a4168.tar.bz2
nixlib-a2c820c6786ef8275213838ad0bdd77b970a4168.tar.lz
nixlib-a2c820c6786ef8275213838ad0bdd77b970a4168.tar.xz
nixlib-a2c820c6786ef8275213838ad0bdd77b970a4168.tar.zst
nixlib-a2c820c6786ef8275213838ad0bdd77b970a4168.zip
Turn security.pam.services into an attribute set
That is, you can say

  security.pam.services.sshd = { options... };

instead of

  security.pam.services = [ { name = "sshd"; options... } ];

making it easier to override PAM settings from other modules.
Diffstat (limited to 'nixos/modules/services/x11/display-managers/lightdm.nix')
-rw-r--r--nixos/modules/services/x11/display-managers/lightdm.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/nixos/modules/services/x11/display-managers/lightdm.nix b/nixos/modules/services/x11/display-managers/lightdm.nix
index c2b90d239eaa..266f16e18e30 100644
--- a/nixos/modules/services/x11/display-managers/lightdm.nix
+++ b/nixos/modules/services/x11/display-managers/lightdm.nix
@@ -102,10 +102,8 @@ in
     services.dbus.enable = true;
     services.dbus.packages = [ lightdm ];
 
-    security.pam.services = [
-      { name = "lightdm"; allowNullPassword = true; startSession = true; }
-      { name = "lightdm-greeter"; allowNullPassword = true; startSession = true; }
-    ];
+    security.pam.services.lightdm = { allowNullPassword = true; startSession = true; };
+    security.pam.services.lightdm-greeter = { allowNullPassword = true; startSession = true; };
 
     users.extraUsers.lightdm = {
       createHome = true;