summary refs log tree commit diff
path: root/nixos/modules/services/x11/colord.nix
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2016-03-15 01:44:24 +0000
committerRobin Gloster <mail@glob.in>2016-03-15 01:44:24 +0000
commit3f45f0948d6fe158bed063adb66850ded0ba4861 (patch)
treeac717689d391d3f5333132fc34e4b2aed829414c /nixos/modules/services/x11/colord.nix
parenta9b942c0617b1cd5f0732d05eadad0114a178f37 (diff)
parentd227d9a70e41d65e4e6f4ac75a9d243c5a19fa85 (diff)
downloadnixlib-3f45f0948d6fe158bed063adb66850ded0ba4861.tar
nixlib-3f45f0948d6fe158bed063adb66850ded0ba4861.tar.gz
nixlib-3f45f0948d6fe158bed063adb66850ded0ba4861.tar.bz2
nixlib-3f45f0948d6fe158bed063adb66850ded0ba4861.tar.lz
nixlib-3f45f0948d6fe158bed063adb66850ded0ba4861.tar.xz
nixlib-3f45f0948d6fe158bed063adb66850ded0ba4861.tar.zst
nixlib-3f45f0948d6fe158bed063adb66850ded0ba4861.zip
Merge remote-tracking branch 'upstream/master' into hardened-stdenv
Diffstat (limited to 'nixos/modules/services/x11/colord.nix')
-rw-r--r--nixos/modules/services/x11/colord.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/nixos/modules/services/x11/colord.nix b/nixos/modules/services/x11/colord.nix
new file mode 100644
index 000000000000..d9e81d750725
--- /dev/null
+++ b/nixos/modules/services/x11/colord.nix
@@ -0,0 +1,39 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+let
+
+  cfg = config.services.colord;
+
+in {
+
+  options = {
+
+    services.colord = {
+      enable = mkEnableOption "colord, the color management daemon";
+    };
+
+  };
+
+  config = mkIf cfg.enable {
+
+    services.dbus.packages = [ pkgs.colord ];
+
+    services.udev.packages = [ pkgs.colord ];
+
+    environment.systemPackages = [ pkgs.colord ];
+
+    systemd.services.colord = {
+      description = "Manage, Install and Generate Color Profiles";
+      serviceConfig = {
+        Type = "dbus";
+        BusName = "org.freedesktop.ColorManager";
+        ExecStart = "${pkgs.colord}/libexec/colord";
+        PrivateTmp = true;
+      };
+    };
+
+  };
+
+}