summary refs log tree commit diff
path: root/nixos/modules/services/web-servers/phpfpm.nix
diff options
context:
space:
mode:
authorRickard Nilsson <rickynils@gmail.com>2014-03-11 23:46:57 +0100
committerRickard Nilsson <rickynils@gmail.com>2014-03-12 11:38:50 +0100
commit562a8ca4a287fb88476496d663864f0746f34d2f (patch)
tree9082f915e1cf1d753fbd418391e5d630e36da9d1 /nixos/modules/services/web-servers/phpfpm.nix
parentc4784335d0d3a3669e06f03a93aaa7df0126bff5 (diff)
downloadnixlib-562a8ca4a287fb88476496d663864f0746f34d2f.tar
nixlib-562a8ca4a287fb88476496d663864f0746f34d2f.tar.gz
nixlib-562a8ca4a287fb88476496d663864f0746f34d2f.tar.bz2
nixlib-562a8ca4a287fb88476496d663864f0746f34d2f.tar.lz
nixlib-562a8ca4a287fb88476496d663864f0746f34d2f.tar.xz
nixlib-562a8ca4a287fb88476496d663864f0746f34d2f.tar.zst
nixlib-562a8ca4a287fb88476496d663864f0746f34d2f.zip
Add phpfpm NixOS service module
Diffstat (limited to 'nixos/modules/services/web-servers/phpfpm.nix')
-rw-r--r--nixos/modules/services/web-servers/phpfpm.nix77
1 files changed, 77 insertions, 0 deletions
diff --git a/nixos/modules/services/web-servers/phpfpm.nix b/nixos/modules/services/web-servers/phpfpm.nix
new file mode 100644
index 000000000000..9be8390fb6ab
--- /dev/null
+++ b/nixos/modules/services/web-servers/phpfpm.nix
@@ -0,0 +1,77 @@
+{ config, pkgs, ... }:
+
+with pkgs.lib;
+
+let
+  cfg = config.services.phpfpm;
+
+  stateDir = "/run/phpfpm";
+
+  pidFile = "${stateDir}/phpfpm.pid";
+
+  cfgFile = pkgs.writeText "phpfpm.conf" ''
+    [global]
+    pid = ${pidFile}
+    error_log = syslog
+    daemonize = yes
+    ${cfg.extraConfig}
+
+    ${concatStringsSep "\n" (mapAttrsToList (n: v: "[${n}]\n${v}") cfg.poolConfigs)}
+  '';
+
+in {
+
+  options = {
+    services.phpfpm = {
+      extraConfig = mkOption {
+        type = types.str;
+        default = "";
+        description = ''
+          Extra configuration that should be put in the global section of
+          the PHP FPM configuration file. Do not specify the options
+          <literal>pid</literal>, <literal>error_log</literal> or
+          <literal>daemonize</literal> here, since they are generated by
+          NixOS.
+        '';
+      };
+
+      poolConfigs = mkOption {
+        type = types.attrsOf types.str;
+        default = {};
+        example = {
+          mypool = ''
+            listen = /run/phpfpm/mypool
+            user = nobody
+            pm = dynamic
+            pm.max_children = 75
+            pm.start_servers = 10
+            pm.min_spare_servers = 5
+            pm.max_spare_servers = 20
+            pm.max_requests = 500
+          '';
+        };
+        description = ''
+          A mapping between PHP FPM pool names and their configurations.
+          See the documentation on <literal>php-fpm.conf</literal> for
+          details on configuration directives. If no pools are defined,
+          the phpfpm service is disabled.
+        '';
+      };
+    };
+  };
+
+  config = mkIf (cfg.poolConfigs != {}) {
+
+    systemd.services.phpfpm = {
+      wantedBy = [ "multi-user.target" ];
+      preStart = ''
+        mkdir -p "${stateDir}"
+      '';
+      serviceConfig = {
+        ExecStart = "${pkgs.php54}/sbin/php-fpm -y ${cfgFile}";
+        PIDFile = pidFile;
+      };
+    };
+
+  };
+}