summary refs log tree commit diff
path: root/nixos/modules/services/web-servers/phpfpm.nix
diff options
context:
space:
mode:
authorDomen Kožar <domen@dev.si>2016-02-27 10:08:37 +0000
committerDomen Kožar <domen@dev.si>2016-02-27 10:08:37 +0000
commit04422bb3ca8f1c09ac45817f6926199f9bfbf84f (patch)
tree6fc31a73fb4595e5f348657cf2f36de90ce606ae /nixos/modules/services/web-servers/phpfpm.nix
parent13afef0d8ec6058e8d42f3ea8cb1f0932bef0c2f (diff)
parent392ca77d4c0c5e05ad23378de370ea964c29848f (diff)
downloadnixlib-04422bb3ca8f1c09ac45817f6926199f9bfbf84f.tar
nixlib-04422bb3ca8f1c09ac45817f6926199f9bfbf84f.tar.gz
nixlib-04422bb3ca8f1c09ac45817f6926199f9bfbf84f.tar.bz2
nixlib-04422bb3ca8f1c09ac45817f6926199f9bfbf84f.tar.lz
nixlib-04422bb3ca8f1c09ac45817f6926199f9bfbf84f.tar.xz
nixlib-04422bb3ca8f1c09ac45817f6926199f9bfbf84f.tar.zst
nixlib-04422bb3ca8f1c09ac45817f6926199f9bfbf84f.zip
Merge pull request #8630 from lihop/nixos/fix-formatting
nixos: fix formatting of option examples
Diffstat (limited to 'nixos/modules/services/web-servers/phpfpm.nix')
-rw-r--r--nixos/modules/services/web-servers/phpfpm.nix25
1 files changed, 13 insertions, 12 deletions
diff --git a/nixos/modules/services/web-servers/phpfpm.nix b/nixos/modules/services/web-servers/phpfpm.nix
index 277180fe139d..6a60000ce19e 100644
--- a/nixos/modules/services/web-servers/phpfpm.nix
+++ b/nixos/modules/services/web-servers/phpfpm.nix
@@ -53,18 +53,19 @@ in {
       poolConfigs = mkOption {
         type = types.attrsOf types.lines;
         default = {};
-        example = {
-          mypool = ''
-            listen = /run/phpfpm/mypool
-            user = nobody
-            pm = dynamic
-            pm.max_children = 75
-            pm.start_servers = 10
-            pm.min_spare_servers = 5
-            pm.max_spare_servers = 20
-            pm.max_requests = 500
-          '';
-        };
+        example = literalExample ''
+          { mypool = '''
+              listen = /run/phpfpm/mypool
+              user = nobody
+              pm = dynamic
+              pm.max_children = 75
+              pm.start_servers = 10
+              pm.min_spare_servers = 5
+              pm.max_spare_servers = 20
+              pm.max_requests = 500
+            ''';
+          }
+        '';
         description = ''
           A mapping between PHP FPM pool names and their configurations.
           See the documentation on <literal>php-fpm.conf</literal> for