summary refs log tree commit diff
path: root/nixos/modules/services/web-servers/apache-httpd/default.nix
diff options
context:
space:
mode:
authorKirill Elagin <kirelagin@gmail.com>2014-06-11 13:17:00 +0400
committerKirill Elagin <kirelagin@gmail.com>2014-06-11 13:17:00 +0400
commit80721cdd41ff107c650e8349a03bea1f6f43cfbb (patch)
tree5395edcf6bebd9ee0d5403fd16006607702966f8 /nixos/modules/services/web-servers/apache-httpd/default.nix
parent08f9da2e8eb9d3da39a1f28e191bd4fb7fd2fa45 (diff)
downloadnixlib-80721cdd41ff107c650e8349a03bea1f6f43cfbb.tar
nixlib-80721cdd41ff107c650e8349a03bea1f6f43cfbb.tar.gz
nixlib-80721cdd41ff107c650e8349a03bea1f6f43cfbb.tar.bz2
nixlib-80721cdd41ff107c650e8349a03bea1f6f43cfbb.tar.lz
nixlib-80721cdd41ff107c650e8349a03bea1f6f43cfbb.tar.xz
nixlib-80721cdd41ff107c650e8349a03bea1f6f43cfbb.tar.zst
nixlib-80721cdd41ff107c650e8349a03bea1f6f43cfbb.zip
Revert "Fix configuring httpd with custom user/group."
This reverts commit 08f9da2e8eb9d3da39a1f28e191bd4fb7fd2fa45.
Diffstat (limited to 'nixos/modules/services/web-servers/apache-httpd/default.nix')
-rw-r--r--nixos/modules/services/web-servers/apache-httpd/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/services/web-servers/apache-httpd/default.nix b/nixos/modules/services/web-servers/apache-httpd/default.nix
index b8359d4756b3..75ec6671d156 100644
--- a/nixos/modules/services/web-servers/apache-httpd/default.nix
+++ b/nixos/modules/services/web-servers/apache-httpd/default.nix
@@ -594,14 +594,14 @@ in
                      message = "SSL is enabled for HTTPD, but sslServerCert and/or sslServerKey haven't been specified."; }
                  ];
 
-    users.extraUsers = optional (mainCfg.user == "wwwrun")
+    users.extraUsers = optionalAttrs (mainCfg.user == "wwwrun") singleton
       { name = "wwwrun";
         group = "wwwrun";
         description = "Apache httpd user";
         uid = config.ids.uids.wwwrun;
       };
 
-    users.extraGroups = optional (mainCfg.group == "wwwrun")
+    users.extraGroups = optionalAttrs (mainCfg.group == "wwwrun") singleton
       { name = "wwwrun";
         gid = config.ids.gids.wwwrun;
       };