summary refs log tree commit diff
path: root/nixos/modules/services/web-apps/tt-rss.nix
diff options
context:
space:
mode:
authorMoritz Ulrich <moritz@tarn-vedra.de>2016-07-22 09:53:00 +0200
committerMoritz Ulrich <moritz@tarn-vedra.de>2016-07-22 09:54:25 +0200
commitf8ea8c7197943b1cc637bd8a796398111185bd1b (patch)
tree5b327bed925d46681c2f0a689747e03ce9229d43 /nixos/modules/services/web-apps/tt-rss.nix
parentd271db550ee72c8693e1bf7deb97bac59bbb50ea (diff)
downloadnixlib-f8ea8c7197943b1cc637bd8a796398111185bd1b.tar
nixlib-f8ea8c7197943b1cc637bd8a796398111185bd1b.tar.gz
nixlib-f8ea8c7197943b1cc637bd8a796398111185bd1b.tar.bz2
nixlib-f8ea8c7197943b1cc637bd8a796398111185bd1b.tar.lz
nixlib-f8ea8c7197943b1cc637bd8a796398111185bd1b.tar.xz
nixlib-f8ea8c7197943b1cc637bd8a796398111185bd1b.tar.zst
nixlib-f8ea8c7197943b1cc637bd8a796398111185bd1b.zip
tt-rss: Fix evaluation by disabling nginx-options.
The nginx.virtualHosts option isn't merged yet. We can re-enable these
features when https://github.com/NixOS/nixpkgs/pull/15862 is merged.
Diffstat (limited to 'nixos/modules/services/web-apps/tt-rss.nix')
-rw-r--r--nixos/modules/services/web-apps/tt-rss.nix68
1 files changed, 35 insertions, 33 deletions
diff --git a/nixos/modules/services/web-apps/tt-rss.nix b/nixos/modules/services/web-apps/tt-rss.nix
index 8ab51c006f27..541aac1d0ef1 100644
--- a/nixos/modules/services/web-apps/tt-rss.nix
+++ b/nixos/modules/services/web-apps/tt-rss.nix
@@ -109,15 +109,17 @@ let
         '';
       };
 
-      virtualHost = mkOption {
-        type = types.str;
-        default = "${virtualHostName}";
-        description = ''
-          Name of existing nginx virtual host that is used to run web-application.
-          If not specified a host will be created automatically with
-          default values.
-        '';
-      };
+      # TODO: Re-enable after https://github.com/NixOS/nixpkgs/pull/15862 is merged
+
+      # virtualHost = mkOption {
+      #   type = types.str;
+      #   default = "${virtualHostName}";
+      #   description = ''
+      #     Name of existing nginx virtual host that is used to run web-application.
+      #     If not specified a host will be created automatically with
+      #     default values.
+      #   '';
+      # };
 
       database = {
         type = mkOption {
@@ -465,33 +467,34 @@ let
       };
     } else {};
 
+    # TODO: Re-enable after https://github.com/NixOS/nixpkgs/pull/15862 is merged
 
-    services.nginx.virtualHosts = if cfg.virtualHost == "${virtualHostName}" then {
-      "${virtualHostName}" = {
-        root = "${root}";
-        extraConfig = ''
-          access_log  /var/log/nginx-${virtualHostName}-access.log;
-          error_log   /var/log/nginx-${virtualHostName}-error.log;
-        '';
+    # services.nginx.virtualHosts = if cfg.virtualHost == "${virtualHostName}" then {
+    #   "${virtualHostName}" = {
+    #     root = "${root}";
+    #     extraConfig = ''
+    #       access_log  /var/log/nginx-${virtualHostName}-access.log;
+    #       error_log   /var/log/nginx-${virtualHostName}-error.log;
+    #     '';
 
-        locations."/" = {
-          extraConfig = ''
-            index index.php;
-          '';
-        };
+    #     locations."/" = {
+    #       extraConfig = ''
+    #         index index.php;
+    #       '';
+    #     };
 
-        locations."~ \.php$" = {
-          extraConfig = ''
-            fastcgi_split_path_info ^(.+\.php)(/.+)$;
-            fastcgi_pass unix:${config.services.phpfpm.pools."${cfg.pool}".listen};
-            fastcgi_index index.php;
-            fastcgi_param SCRIPT_FILENAME ${root}/$fastcgi_script_name;
+    #     locations."~ \.php$" = {
+    #       extraConfig = ''
+    #         fastcgi_split_path_info ^(.+\.php)(/.+)$;
+    #         fastcgi_pass unix:${config.services.phpfpm.pools."${cfg.pool}".listen};
+    #         fastcgi_index index.php;
+    #         fastcgi_param SCRIPT_FILENAME ${root}/$fastcgi_script_name;
 
-            include ${pkgs.nginx}/conf/fastcgi_params;
-          '';
-        };
-      };
-    } else {};
+    #         include ${pkgs.nginx}/conf/fastcgi_params;
+    #       '';
+    #     };
+    #   };
+    # } else {};
 
 
     systemd.services.tt-rss = let
@@ -564,4 +567,3 @@ let
     };
   };
 }
-