summary refs log tree commit diff
path: root/nixos/modules/services/web-apps/mattermost.nix
diff options
context:
space:
mode:
authorRyan Mulligan <ryan@ryantm.com>2017-09-01 14:24:44 -0700
committerRyan Mulligan <ryan@ryantm.com>2017-09-01 14:24:44 -0700
commit8585898909e9a68c97483316d7c50a2d8135d8e1 (patch)
tree4c758740988eb421b723760f42226b2339975e60 /nixos/modules/services/web-apps/mattermost.nix
parent82c493d37c320e45da8db9ae8daa784a80c50cef (diff)
downloadnixlib-8585898909e9a68c97483316d7c50a2d8135d8e1.tar
nixlib-8585898909e9a68c97483316d7c50a2d8135d8e1.tar.gz
nixlib-8585898909e9a68c97483316d7c50a2d8135d8e1.tar.bz2
nixlib-8585898909e9a68c97483316d7c50a2d8135d8e1.tar.lz
nixlib-8585898909e9a68c97483316d7c50a2d8135d8e1.tar.xz
nixlib-8585898909e9a68c97483316d7c50a2d8135d8e1.tar.zst
nixlib-8585898909e9a68c97483316d7c50a2d8135d8e1.zip
nixos/mattermost: fix create role
postgresql create role no longer supports NOCREATEUSER option. See
https://www.postgresql.org/docs/9.6/static/release-9-6.html for
details.
Diffstat (limited to 'nixos/modules/services/web-apps/mattermost.nix')
-rw-r--r--nixos/modules/services/web-apps/mattermost.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/web-apps/mattermost.nix b/nixos/modules/services/web-apps/mattermost.nix
index be9af78da181..bc88a808abc9 100644
--- a/nixos/modules/services/web-apps/mattermost.nix
+++ b/nixos/modules/services/web-apps/mattermost.nix
@@ -185,7 +185,7 @@ in
         '' + lib.optionalString cfg.localDatabaseCreate ''
           if ! test -e "${cfg.statePath}/.db-created"; then
             ${config.services.postgresql.package}/bin/psql postgres -c \
-              "CREATE ROLE ${cfg.localDatabaseUser} WITH LOGIN NOCREATEDB NOCREATEROLE NOCREATEUSER ENCRYPTED PASSWORD '${cfg.localDatabasePassword}'"
+              "CREATE ROLE ${cfg.localDatabaseUser} WITH LOGIN NOCREATEDB NOCREATEROLE ENCRYPTED PASSWORD '${cfg.localDatabasePassword}'"
             ${config.services.postgresql.package}/bin/createdb \
               --owner ${cfg.localDatabaseUser} ${cfg.localDatabaseName}
             touch ${cfg.statePath}/.db-created